Closed Bug 1540818 Opened 3 years ago Closed 3 years ago

Crash in [@ mozilla::dom::WebAuthnManagerBase::StopListeningForVisibilityEvents]

Categories

(Core :: DOM: Web Authentication, defect)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1541085
Tracking Status
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-643a6d7b-345c-4d0b-8c16-fc8ad0190331.

Small volume Mac regression which started in 20190330093331: https://bit.ly/2VaauOF.

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=401af0fbedf390d4fdc42943a260e58462a740ea&tochange=eab754e02657af34096c2a5a79c208d393a72830

Top 10 frames of crashing thread:

0 XUL mozilla::dom::WebAuthnManagerBase::StopListeningForVisibilityEvents xpcom/base/nsCOMPtr.h:823
1 XUL mozilla::dom::U2F::RejectTransaction dom/u2f/U2F.cpp:528
2 XUL mozilla::dom::U2F::~U2F dom/u2f/U2F.cpp:135
3 XUL mozilla::dom::U2F::~U2F dom/u2f/U2F.cpp:131
4 XUL SnowWhiteKiller::Visit xpcom/base/nsCycleCollector.cpp:2428
5 XUL void nsPurpleBuffer::VisitEntries<SnowWhiteKiller> xpcom/base/nsCycleCollector.cpp:956
6 XUL AsyncFreeSnowWhite::Run xpcom/base/nsCycleCollector.cpp:2622
7 XUL <name omitted> xpcom/threads/nsThreadUtils.cpp:327
8 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
9 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:482

A few Windows crashes as well, so changing affected platforms.

OS: macOS → All
Hardware: Unspecified → All

There are some Linux crashes as well, including one in 67. So this might be something that goes further back than 68. Overall this is a fairly low volume crash.

Component: DOM: Device Interfaces → DOM: Web Authentication
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1541085
You need to log in before you can comment on or make changes to this bug.