Extension Block Request: adobe-flash-player-new

RESOLVED FIXED

Status

()

task
RESOLVED FIXED
5 months ago
4 months ago

People

(Reporter: Spoji, Assigned: Fallen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Extension name adobe-flash-player-new
Extension versions affected <all versions>
Platforms affected <all platforms>
Block severity hard

Reason

Code is a key logger.

Extension GUIDs

{25b3b5bc-b77a-49d1-ab56-c0e760fe02ff}

Additional Information

Codebase is very much similar to what has been blocked before on hxxps://bugzilla.mozilla.org/show_bug.cgi?id=1539910

Clone:{74480b2f-1198-45b3-86b3-ca0778482216}

Assignee: nobody → philipp
Status: NEW → ASSIGNED
Type: defect → task

I've reviewed the add-ons and have determined that these are exfiltrating user data to a remote site while masking as a different add-on. The following clones exist:

{02acc043-f402-4e48-aa15-56ee1364e17c}
{1b7892ab-6dbe-49d1-9c71-bbb70458c830}
{25b3b5bc-b77a-49d1-ab56-c0e760fe02ff}
{2c78aa89-8cdd-4a96-821a-e35628aea2fb}
{2f154b99-05c2-4629-b687-f2aa031d9f65}
{36df6f78-16c4-42c2-a6b8-9210a2953739}
{40ada62f-72a8-46b7-8e50-4153f660ce34}
{49f58462-fc24-472c-b85a-4a3dbbf48741}
{4a8cb3fd-0400-47b3-a799-9f2964229bfa}
{5429f6da-d7fe-4f1b-a85e-6dc721ec0037}
{743fc0de-1085-4078-8611-848024989608}
{74480b2f-1198-45b3-86b3-ca0778482216}
{777f1169-a824-459d-8a2d-ca2ffaf59424}
{81e610be-656a-4a71-866d-dd94b5096c60}
{81ee3e70-b6e4-44d0-b5c2-94ded26bb5ac}
{881c71c1-6800-4e8b-89de-0d14ef67d588}
{9b5d7f59-be9c-4f1e-bf0c-31f085c17726}
{9eff0ead-25a4-429c-b4b2-280ba3c6f2d9}
{ad1b7e87-e260-4aee-a602-ef234743443e}
{b54a530a-cacc-4c76-a7c3-feafd4ce0b13}
{bd0d7634-770e-4d9f-8309-d264a5fbbfa9}
{bdf16cc8-3da6-4317-a1eb-2ab8adce6b66}
{bf484a7f-49fd-4681-afa5-8a063d010a14}
{c7cf6d86-207b-4231-a96a-bbfdc9fe59aa}
{d33f83c2-dbc6-41d2-a8b9-28fdaa96985e}
{d71757ee-edc7-44d5-b536-cb0370d7d9f6}
{daf86db4-7dd4-47d4-a1d1-7c31f6b9bbe3}
{e27060a0-5fb5-4844-b446-d2655d7681fa}
{fae0d133-05dd-44e6-88e1-e218ca2b2caf}
{fbf69005-55d8-4360-a562-255a8c285fea}
{fd6d1b53-89f5-4d91-9234-fb3e1b067c1b}
{bf163ed1-e9f9-4c98-ae4b-8391133472d1}
{ec283482-2d66-49b2-9dc5-0d03bcbffe65}
{0a19856e-4168-4765-a8ab-a3a34fa88ec1}
{e2019dd1-4591-42e2-864a-535a99972b1a}
{88a65f0c-f952-41f0-8868-f22fa12597b3}

Duplicate of this bug: 1542275

The block has been staged. Andreas, can you review and push?

Flags: needinfo?(awagner)

Done

Status: ASSIGNED → RESOLVED
Closed: 4 months ago4 months ago
Flags: needinfo?(awagner)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.