Stray </NOSCRIPT> confuses parser

VERIFIED DUPLICATE of bug 15346

Status

()

Core
HTML: Parser
P3
normal
VERIFIED DUPLICATE of bug 15346
19 years ago
18 years ago

People

(Reporter: olaf, Assigned: rickg)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The page above comes up blank in build #1999082316. (It seems to have worked
some days ago, but unfortunately they also changed the page layout, so I am not
sure.)
The page contains a JS script which emits some document stuff and <NOSCRIPT>,
followed by replacement text and </NOSCRIPT>, like this:

--cut--

<!-- Add-Ad Start -->
<CENTER>
<IFRAME...>
<SCRIPT><!--
document.write("stuff for use with JS <NOSCRIPT>");
//--></SCRIPT>
stuff for use without JS
</NOSCRIPT>
</IFRAME>
</CENTER>
<!-- Add Ad End -->

--cut--

Now the parsing seems to get confused by the single </NOSCRIPT> in the HTML.
The DOM viewer shows as last recognized node the first "Add-Ad Start" comment,
so it could even be an interaction with the IFRAME.

Of course the whole HTML construct is rather questionable, but when I remove
the </NOSCRIPT> tag it works.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 15346 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
verified
You need to log in before you can comment on or make changes to this bug.