{css2} Big problems with positioned elements inside fixed positioned ones

VERIFIED DUPLICATE of bug 4209

Status

()

defect
P3
normal
VERIFIED DUPLICATE of bug 4209
20 years ago
20 years ago

People

(Reporter: ian.graham, Assigned: troy)

Tracking

({css2})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

[Seamonkey M9 build]
If a position: fixed element contains other positioned
content, then this internal content is not rendered properly.
The URL provides a page that links to 3 examples illustrating
these problems.

THe first example
(http://smaug.java.utoronto.ca/NS5-bugs/pos-fixed-bug1.html)
shows absolutely positioned content --
an absolutely positioned element containing 4 absolutely positioned
elements. This is succesfully rendered according to the CSS spec.

The second example
(http://smaug.java.utoronto.ca/NS5-bugs/pos-fixed-bug2.html)
is changed form the first only in that the positioning of the outer
containing element is changed from "absolute" to "fixed".
According to CSS 2 9.6.1, fixed positioning is a subset of
absolute -- so that the rendering
should be the same as in the first example, except taht the fixed
element and its content should not scroll with the document. This
does nto happen. The "absolutely" positioned elements inside the
"fixed" one are largely clipped at the pareng element edge, while
there is some weird formatting problem at the bottom of the element
where the text of the fixed div 'overflows' the element bounds.

The third example
(http://smaug.java.utoronto.ca/NS5-bugs/pos-fixed-bug3.html)
shows what happend when all elements are position: fixed.
The rendering is even worse -- the internal fixed divs
are positioned all over the page, and tend to display graphic
content that is "grabbed" somehow from the toolbar area.


NOTE: Viewing these last two pages a sufficient number of times will crash
Seamonkey, and can also crash Windows 98.
Assignee: peterl → troy
Component: Style System → Layout
Summary: Big problems with positioned elements inside fixed positioned ones → {css2} Big problems with positioned elements inside fixed positioned ones
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is a DUP of 4209. It's a known problem with fixed positioning. The basic
issue is that to get fixed positioning to work I made the fixed positioned
elements have a native window. That way they displayed properly over the
viewport.

The downside to what I did is that it only works if the element has an explicit
background specified. The default for 'background' is 'none', of course, which
is why you see problems

That's only meant to be temporary until bug #4209 is fixed.


*** This bug has been marked as a duplicate of 4209 ***
Status: RESOLVED → VERIFIED
Verified dup of #4209
Keywords: css2
Migrating from {css2} to css2 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
You need to log in before you can comment on or make changes to this bug.