Closed Bug 1541452 Opened 7 months ago Closed 3 months ago

[webvtt] Cue doesn't show in correct position, when window resizes and an explicit CSS 'width' applied on video in percentage

Categories

(Core :: Audio/Video: Playback, defect, P2)

65 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- verified

People

(Reporter: be.davestein, Assigned: alwu)

References

(Blocks 1 open bug)

Details

Attachments

(7 files)

Attached file testcaptions.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Steps to reproduce:

See attached file. Hit play on video. Pause when you see captions. Resize window.

Actual results:

The captions did not move to proper location

Expected results:

The captions should have moved

BTW if you resize down, the captions can actually appear over the window rather than the video even. Seems to be fixed position.

Hi be.davestein, I have tested this issue on latest Nightly version (68.0a1 (2019-04-09) (64-bit)) using Win 10 and macOS and I wasn't able to reproduce it.

Can you please try to retest this on the latest Nightly Version?
You can downloaded to https://www.mozilla.org/en-US/firefox/nightly/all/

Can you please attach a screen recording with the issue in case you can reproduce it on Nightly?

Flags: needinfo?(be.davestein)

Marking this as Resolved-Incomplete due to the lack of response from the reporter.
If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → INCOMPLETE

Sorry for extreme delay. Can't reproduce as I try on laptop on FF 61. Will try one more time tomorrow with a large monitor. Might have to do with max size of video against max size of my screen.

Flags: needinfo?(be.davestein)
Attached file captions.vtt

I somehow missed the sample captions file from original report

I reproduced on my work machine. I'm on macOS Mojave. 10.14.4. This is on FF 68.0.3. I just updated.

This is very easy to reproduce on any sized monitor. I tried both on my laptop 15" screen and the 30" 4K monitor I have.

Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

I was able to reproduce it on latest Nightly 69.0a1 (2019-06-19) with Mac 10.14.4 and Windows 10.

[Affected platforms]:
Platforms: mac 10.14.4 and Windows 10

Status: UNCONFIRMED → NEW
Component: Untriaged → Audio/Video: Playback
Ever confirmed: true
Product: Firefox → Core
Priority: -- → P2
Assignee: nobody → alwu
Blocks: webvtt
Summary: Cue does not change position with window resize → [webvtt] Cue doesn't show in correct position, when window resize and an explicit CSS 'width' in percentage applied on video
Summary: [webvtt] Cue doesn't show in correct position, when window resize and an explicit CSS 'width' in percentage applied on video → [webvtt] Cue doesn't show in correct position, when window resizes and an explicit CSS 'width' applied on video in percentage

When window is resized, the cue would usually be zoomed in or out automatically with the video and keep its relative position to video.

However, if video is being applied the explicit percentage value on its 'width' or 'height', we have to recompute cue's position in this situation, because the width or height of the video would be scaled again after applied the first size scaled which is caused by resizing.

Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/16485dcacef6
update cue display when window is resized. r=heycam
Status: NEW → RESOLVED
Closed: 6 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Flags: qe-verify+

Confirming this issue in Beta 67.0 (20190516215225) on Mac OS 10.14.4
Verified - Fixed on Beta 69.0b5 (20190715173502), on Mac OS 10.14.4

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1580015
You need to log in before you can comment on or make changes to this bug.