Closed Bug 1541553 Opened 9 months ago Closed 8 months ago

Once a non-zero RTT is reported we are allowed to report RTTs of zero, we should do so

Categories

(Core :: WebRTC, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: ng, Assigned: ng)

Details

Attachments

(1 file)

Once a non-zero RTT is reported we are allowed to report RTTs of zero, we should. Pending spec changes we may be able to report initial zeros as well. This may help with the intermittent failures on bug 1373123 whenever they are not caused by a complete lack of RTCP.

roundTripTime can be zero once it has been non-zero this should help with intermitents in WPT and mochitests

Assignee: nobody → na-g
Summary: Once a non-zero RTT is reported we are allowed to report RTTs of zero, we should → Once a non-zero RTT is reported we are allowed to report RTTs of zero, we should do so

This patch also changes the round trip time units on the API interface to match what is in the WebIDL.

Rank: 15
Priority: -- → P2
Pushed by na-g@nostrum.com:
https://hg.mozilla.org/integration/autoland/rev/8e81194c97ea
allow RTCRtpReceiverStats roundTripTime of 0 after non-zero values have been reported r=bwc
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.