hack to make existing linux flashplayer binary work with gcc 3.1 builds

VERIFIED DUPLICATE of bug 154206

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 154206
16 years ago
15 years ago

People

(Reporter: dmose, Assigned: dmose)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
On x86 linux, the current flashplayer plugin (version 5.0r48) expects 
a couple of builtin symbols from libgcc which were available in some older
versions of gcc.  However, they're _NOT_ available in gcc 3.1, so if we 
want that plugin to work with a gcc-3.1 built binary, we need to provide these
symbols.

It turns out that all the rest of the C++ goop in flashplayer is linked
statically, so there are no ABI issues here.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 154206 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.