Closed Bug 1542102 Opened 5 months ago Closed 4 months ago

IndexedDB fails in Focus 8.0.8 + GV 65

Categories

(GeckoView :: General, defect, P3)

Unspecified
Android
defect

Tracking

(firefox66 wontfix, firefox67 affected, firefox68 affected)

RESOLVED DUPLICATE of bug 781982
Tracking Status
firefox66 --- wontfix
firefox67 --- affected
firefox68 --- affected

People

(Reporter: cpeterson, Unassigned)

References

()

Details

This bug was originally filed on the WebCompat issue tracker:
https://webcompat.com/issues/28402

STR:

  1. Load https://rie.cl/?ps=410 in Focus 8.0.0 (GV 65).

RESULT:
The page shows a pop-up saying "errror" [sic] instead of loading the content.

I can reproduce bug in Focus 8.0.0 (GV 65), but not in:

Focus 6.1.1 (WebView)
Fennec 66
Fennec 67 Beta
Fennec 68 Nightly
Fenix (GV 67)
Reference Browser (GV 68)

Tom Wisniewski isolated a simple test case that reproduces the problem in Focus + GV 65:

var request = window.indexedDB.open("pwa", 1);request.onerror = function(event){alert('errror');console.log("error: ");};

I can confirm this is still present in Focus w/ GV68.

(In reply to Dylan Roeh (:droeh) (he/him) from comment #1)

I can confirm this is still present in Focus w/ GV68.

Interesting. Since this bug only appears to affect Focus + GV (and not GV in Fenix or RB), this is probably a Focus bug. Users wouldn't want to save IndexedDB in the private browser anyways. I'm going to WONTFIX this bug until another GV-powered app has the same problem.

Status: NEW → RESOLVED
Closed: 5 months ago
Priority: -- → P3
Resolution: --- → WONTFIX

Had a late night thought on this and tested to confirm: it's private browsing mode that causes the error here. With private browsing enabled it reproduces on both Fenix and Fennec. Reopening so we can re-triage Thursday.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

(In reply to Dylan Roeh (:droeh) (he/him) from comment #3)

Had a late night thought on this and tested to confirm: it's private browsing mode that causes the error here. With private browsing enabled it reproduces on both Fenix and Fennec. Reopening so we can re-triage Thursday.

And desktop, for that matter. This might just be desired behavior for private browsing.

(In reply to Dylan Roeh (:droeh) (he/him) from comment #4)

And desktop, for that matter. This might just be desired behavior for private browsing.

In that case, this is a dupe of seven-year-old "IndexedDB doesn't work in Private Browsing Mode" bug 781982. It's not desired behavior, but fixing it could be a lot of work and has been a low priority for desktop. IndexedDB does work in Chrome's Incognito Mode.

Status: REOPENED → RESOLVED
Closed: 5 months ago4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 781982
You need to log in before you can comment on or make changes to this bug.