Open Bug 1542144 Opened 1 year ago Updated 13 days ago

Intermittent fission devtools/client/storage/test/browser_storage_cookies_domain.js | There is correct number of rows in cookies > http://test1.example.org - Got 11, expected 5

Categories

(DevTools :: Storage Inspector, defect, P5)

defect

Tracking

(Fission Milestone:M6)

REOPENED
Fission Milestone M6

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, leave-open, regression)

Attachments

(1 file)

#[markdown(off)]
Filed by: btara [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=238318350&repo=mozilla-central

https://queue.taskcluster.net/v1/task/GeQJ9lkZS5CPpkEZEq8VbQ/runs/0/artifacts/public/logs/live_backing.log

05:40:19 INFO - TEST-START | devtools/client/storage/test/browser_storage_cookies_domain.js
05:40:19 INFO - Not taking screenshot here: see the one that was previously logged
05:40:19 INFO - Buffered messages logged at 05:40:18
05:40:19 INFO - Entering test bound
05:40:19 INFO - Adding a new tab with URL: http://test1.example.org/browser/devtools/client/storage/test/storage-cookies.html
05:40:19 INFO - Buffered messages logged at 05:40:19
05:40:19 INFO - Tab added and finished loading
05:40:19 INFO - Found a window: complete
05:40:19 INFO - Opening the storage inspector
05:40:19 INFO - Opening the toolbox
05:40:19 INFO - Console message: [JavaScript Warning: "XUL box for vbox element contained an inline label child, forcing all its children to be wrapped in a block." {file: "chrome://devtools/content/storage/index.xul" line: 0}]
05:40:19 INFO - Waiting for the stores to update
05:40:19 INFO - Making sure that the toolbox's frame is focused
05:40:19 INFO - Selecting tree item cookies > http://test1.example.org
05:40:19 INFO - "cookies,http://test1.example.org" is already selected, returning.
05:40:19 INFO - Buffered messages finished
05:40:19 INFO - TEST-UNEXPECTED-FAIL | devtools/client/storage/test/browser_storage_cookies_domain.js | There is correct number of rows in cookies > http://test1.example.org - Got 11, expected 5
05:40:19 INFO - Stack trace:
05:40:19 INFO - chrome://mochikit/content/browser-test.js:test_is:1325
05:40:19 INFO - chrome://mochitests/content/browser/devtools/client/storage/test/head.js:checkState:896
05:40:19 INFO - chrome://mochitests/content/browser/devtools/client/storage/test/browser_storage_cookies_domain.js:null:15
05:40:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1116
05:40:19 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1144
05:40:19 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1005
05:40:19 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
05:40:19 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cookies_domain.js | There is item with name 'test1{9d414cc5-8319-0a04-0586-c0a6ae01670a}.test1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser' in cookies > http://test1.example.org -
05:40:19 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cookies_domain.js | There is item with name 'test2{9d414cc5-8319-0a04-0586-c0a6ae01670a}test1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser' in cookies > http://test1.example.org -
05:40:19 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cookies_domain.js | There is item with name 'test3{9d414cc5-8319-0a04-0586-c0a6ae01670a}.test1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser' in cookies > http://test1.example.org -
05:40:19 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cookies_domain.js | There is item with name 'test4{9d414cc5-8319-0a04-0586-c0a6ae01670a}test1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser' in cookies > http://test1.example.org -
05:40:19 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cookies_domain.js | There is item with name 'test5{9d414cc5-8319-0a04-0586-c0a6ae01670a}.test1.example.org{9d414cc5-8319-0a04-0586-c0a6ae01670a}/browser' in cookies > http://test1.example.org -
05:40:19 INFO - GECKO(4148) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn7.child1/context18' can't be sent as the connection is closed."
05:40:20 INFO - Removing tab.
05:40:20 INFO - Waiting for event: 'TabClose' on [object XULElement].
05:40:20 INFO - Got event: 'TabClose' on [object XULElement].
05:40:20 INFO - Tab removed and finished closing
05:40:20 INFO - Leaving test bound
05:40:20 INFO - GECKO(4148) | MEMORY STAT | vsize 5852MB | vsizeMaxContiguous 68208088MB | residentFast 248MB | heapAllocated 91MB
05:40:20 INFO - TEST-OK | devtools/client/storage/test/browser_storage_cookies_domain.js | took 1399ms

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

New occurrence : https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=263383725&repo=mozilla-central&lineNumber=7463

Log snippet:
[task 2019-08-25T10:47:25.535Z] 10:47:25 INFO - Entering test bound
[task 2019-08-25T10:47:25.536Z] 10:47:25 INFO - Adding a new tab with URL: http://test1.example.org/browser/devtools/client/storage/test/storage-cookies.html
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Buffered messages logged at 10:47:23
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Tab added and finished loading
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Found a window: complete
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Opening the storage inspector
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Opening the toolbox
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Buffered messages logged at 10:47:24
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Waiting for the stores to update
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Buffered messages logged at 10:47:25
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Making sure that the toolbox's frame is focused
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Selecting tree item cookies > http://test1.example.org
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - "cookies,http://test1.example.org" is already selected, returning.
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Buffered messages finished
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - TEST-UNEXPECTED-FAIL | devtools/client/storage/test/browser_storage_cookies_domain.js | There is correct number of rows in cookies > http://test1.example.org - Got 11, expected 5
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - Stack trace:
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - chrome://mochikit/content/browser-test.js:test_is:1595
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - chrome://mochitests/content/browser/devtools/client/storage/test/head.js:checkState:943
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - chrome://mochitests/content/browser/devtools/client/storage/test/browser_storage_cookies_domain.js:null:15
[task 2019-08-25T10:47:25.537Z] 10:47:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1350
[task 2019-08-25T10:47:25.538Z] 10:47:25 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1385
[task 2019-08-25T10:47:25.539Z] 10:47:25 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:1213
[task 2019-08-25T10:47:25.540Z] 10:47:25 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:805

The new occurances are all fission.

Summary: Intermittent devtools/client/storage/test/browser_storage_cookies_domain.js | There is correct number of rows in cookies > http://test1.example.org - Got 11, expected 5 → Intermittent fission devtools/client/storage/test/browser_storage_cookies_domain.js | There is correct number of rows in cookies > http://test1.example.org - Got 11, expected 5

Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2d1de0e7bbae
Annotate test on fission cause on debug failures. r=pbone

Keywords: checkin-needed
See Also: → 1578830

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:CosminS, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(csabou)

It was landed on inbound with comment 9.

Flags: needinfo?(csabou)

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?
Fission Milestone: ? → M4.1

Julian, this bug is a blocker for Fission's current milestone (M4.1 aka "fix all the mochitests"), but it's currently unassigned. The Fission team is hoping teams will fix their mochitests for Fission before the end of Q1 (75 or 76 Nightly).

Will your team be able to prioritize this bug for Q1? If you don't think this debug mochitest failure should block shipping Fission, just let me know.

If you have questions for Fission engineers, you can reach them in the #fission channel on Slack or Riot.

Flags: needinfo?(jdescottes)

Hi Chris!

We initially said that DevTools mochitests would be converted in a later milestone, because they need DevTools to work with Fission in order to work and that's a big undertaking.

I don't think other DevTools tests have been similarly flagged for M4.1, could we check if this test was not categorized correctly for some reason?

Flags: needinfo?(jdescottes) → needinfo?(cpeterson)

(In reply to Julian Descottes [:jdescottes] from comment #16)

We initially said that DevTools mochitests would be converted in a later milestone, because they need DevTools to work with Fission in order to work and that's a big undertaking.

I don't think other DevTools tests have been similarly flagged for M4.1, could we check if this test was not categorized correctly for some reason?

In that case, we can track this and other devtools test bugs from M4.1 to our Fission Nightly (M6) milestone.

Fission Milestone: M4.1 → M6
Flags: needinfo?(cpeterson)
You need to log in before you can comment on or make changes to this bug.