Closed Bug 1542244 Opened 8 months ago Closed 6 months ago

Disable tracking protection and dom push

Categories

(Testing :: Marionette, task, P1)

task

Tracking

(firefox69 fixed)

RESOLVED FIXED
mozilla69
Tracking Status
firefox69 --- fixed

People

(Reporter: tarek, Assigned: automatedtester)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

per Henrik: We should really disable tracking and the requests to push.services.mozilla.com by default in Marionette.

We can disable tracking protection by setting privacy.trackingprotection.enabled = false. Maybe we can even remove browser.contentblocking.introCount which is already set in geckoinstance.py because we now completely disable the feature.

In regards of push.services.mozilla.com this should come from dom.push.serverURL, and we should be able to turn off the feature by setting dom.push.connection.enabled = false.

Blocks: 1371576
Summary: Disable a few services + tracking protection → Disable tracking protection and dom push

(In reply to Henrik Skupin (:whimboo) [⌚️UTC+1] from comment #1)

We can disable tracking protection by setting privacy.trackingprotection.enabled = false. Maybe we can even remove browser.contentblocking.introCount which is already set in geckoinstance.py because we now completely disable the feature.

Note that tracking protection (aka Trackers) is just a subset of content blocking, and as browser.contentblocking.introCount has to be kept.

The priority flag is not set for this bug.
:automatedtester, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dburns)
Flags: needinfo?(dburns)
Priority: -- → P3
Type: defect → task
Assignee: nobody → dburns

When privacy and tracking protection is enabled there is a call home that
can break tests. This uses the relavant prefs to disable the features.

Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1efcba0d56db
Disable Privacy and tracking protection features during testing. r=webdriver-reviewers,ato,whimboo
Flags: needinfo?(dburns)
Pushed by dburns@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3e5aa7cb7460
Disable Privacy and tracking protection features during testing. r=webdriver-reviewers,ato,whimboo
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
Flags: needinfo?(dburns)
Regressions: 1554225

Sheriffs please backout this patch, given that it modified the global defaults for the preferences, as such both tracking protection and DOM push are no longer enabled by default in Nightly!

Flags: needinfo?(sheriffs)
Version: Version 3 → Trunk
Backout by opoprus@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/944c410b7e91
Backed out changeset 3e5aa7cb7460 for causing broken nightly builds a=backout

Backed out changeset 3e5aa7cb7460 (bug 1542244) for causing broken nightly builds, as requested by whimboo.

Backout: https://hg.mozilla.org/mozilla-central/rev/944c410b7e9185a0cb90a4fbc0970299f1ff3e2b

Status: RESOLVED → REOPENED
Flags: needinfo?(dburns)
Resolution: FIXED → ---
Target Milestone: mozilla69 → ---
Status: REOPENED → ASSIGNED
Priority: P3 → P1
Flags: needinfo?(dburns)
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b5dfe6e88cc
Disable Privacy and tracking protection features during testing. r=webdriver-reviewers,ato,whimboo
Status: ASSIGNED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.