certificate manager needs to allow importing full p12 chain on a hardware token

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: julien.pierre, Unassigned)

Tracking

(Blocks: 1 bug)

Other Branch
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kerh-coz])

(Reporter)

Description

17 years ago
Currently, when doing a P12 import, CMS calls the NSS P12 import functions,
which import the leaf cert on the selected token, and all the other certs in the
softoken. This gets in the way of portability of smartcards. PSM needs to call a
new NSS function to import all the certs to the hardware token. See bug 142889.
(Reporter)

Updated

17 years ago
Depends on: 142889
Summary: certificate manger needs to allow importing full p12 chain on a hardware token → certificate manager needs to allow importing full p12 chain on a hardware token
(Reporter)

Updated

17 years ago
Blocks: 154246
142889 was marked a duplicate of 142867.  That bug is fixed in NSS 3.8
Depends on: 142867

Comment 2

15 years ago
Mass reassign ssaux bugs to nobody
Assignee: ssaux → nobody

Comment 3

14 years ago
I believe that I have confirmed that this bug is still alive in Firefox 1.0
Preview Release.  I'm using a Schlumberger smartcard and the Litronics
NetsignCAC PKCS#11 module.  Accessing sites that require client certificates
works fine in IE, but doesn't work in Firefox or Netscape 7.1.  (Or rather, it
works for some sites, but not others.)  After I explicitly added the chaining
certs as recognized CAs, then it the cert on the smartcard does work.  

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

13 years ago
Whiteboard: [kerh-coz]
QA Contact: junruh → ui
I don't think it's Firefox's role to implement this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.