Closed Bug 1542705 Opened 5 months ago Closed 5 months ago

Crash in [@ PLDHashTable::Remove | mozilla::dom::(anonymous namespace)::Snapshot::Finish]

Categories

(Core :: DOM: Web Storage, defect, critical)

Unspecified
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1542706

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-ac485349-9729-4887-8e4b-27f980190407.

Top 10 frames of crashing thread:

0 XUL PLDHashTable::Remove xpcom/ds/PLDHashTable.cpp:604
1 XUL mozilla::dom:: xpcom/ds/nsTHashtable.h:191
2 XUL mozilla::dom::PBackgroundLSDatabaseParent::DestroySubtree ipc/ipdl/PBackgroundLSSnapshotParent.cpp:385
3 XUL mozilla::ipc::PBackgroundParent::DestroySubtree ipc/ipdl/PBackgroundParent.cpp:4905
4 XUL mozilla::ipc::PBackgroundParent::OnChannelError ipc/ipdl/PBackgroundParent.cpp:4851
5 XUL mozilla::detail::RunnableMethodImpl<mozilla::ipc::MessageChannel*, void  xpcom/threads/nsThreadUtils.h:1122
6 XUL nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
7 XUL NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
8 XUL mozilla::ipc::MessagePumpForNonMainThreads::Run ipc/glue/MessagePump.cpp:303
9 XUL nsThread::ThreadFunc ipc/chromium/src/base/message_loop.cc:315

These Mac crashes started in 20190405095028 and seem to affect all versions of Mac. https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=82ba38c4aa6acc7b322bcb56c417c0f64d5d3660&tochange=8cc6d083001bd54e17fd6b332807f32b6e336d96 is the set of changes that went in between those builds.

I think this is a dupe of bug 1542706, which was filed next, but has a little more activity.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1542706
You need to log in before you can comment on or make changes to this bug.