Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1542440
4 months ago
4 months ago

People

(Reporter: mirabela.lobontiu, Unassigned)

Tracking

({crash, regression})

Firefox 68
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox68 fixed)

Details

(Whiteboard: crash, regression, crash signature)

This bug is for crash report bp-3c8bb87e-3175-4e0a-9da7-e45d10190408.

Top 10 frames of crashing thread:

0 libc.so libc.so@0x21d54 
1 libc.so libc.so@0x21d24 
2 libart.so libart.so@0x46fcc0 
3 libbase.so libbase.so@0x8d2c 
4 libart.so libart.so@0x2ecb20 
5 libart.so libart.so@0x348278 
6 libxul.so void mozilla::jni::Method<mozilla::java::CodecProxy::DisposeOutput_t, void>::Call<mozilla::jni::Ref<mozilla::jni::Object, _jobject*> > android-ndk/sysroot/usr/include/jni.h:639
7 libxul.so mozilla::detail::RunnableMethodImpl<mozilla::RemoteAudioDecoder*, void  xpcom/threads/nsThreadUtils.h:1122
8 libxul.so mozilla::TaskQueue::Runner::Run xpcom/threads/TaskQueue.cpp:199
9 libxul.so nsThreadPool::Run xpcom/threads/nsThreadPool.cpp:244

STR:
Steps to reproduce:

  1. There were about 13 tabs with the most common websites (Google docs, theguardian.com, ebay.com, twitch.tv, aliexpress.com, spiegel.de, bloomberg.com, rottentomatoes.com, flickr.com, 9.gag.com, and others)
  2. Watching a .gif on https://m.9gag.com crashed Nightly.

[Tracking Requested - why for this release]: I see a bunch of different signatures that seem to be crashing with slightly different signatures, but with MediaPDecoder #3 at the top of the threads. The combination of all these signatures will easily make this the top crash on Fennec 68.

For example, https://bit.ly/2UoosQI is a crash that just affects huawei devices running API 28. Some of the other signatures are Samsung devices running API 28.

Mirabela was this crash reproducible for you? I will try to hunt down a regression range to see when exactly these started happening.

Crash Signature: [@ libart.so@0x46fcc0] → [@ libart.so@0x46fcc0] [@ libart.so@0x47a8a8] [@ libart.so@0x46f6d8] [@ libart.so@0x4380cc] [@ libart.so@0x4645d8] [@ libart.so@0x4657f4] [@ libart.so@0x437450] [@ libart.so@0x464528] [@ libart.so@0x456cac] [@ libart.so@0x35ce9b]
Flags: needinfo?(mirabela.lobontiu)
Whiteboard: crash, regression

It is reproducible using https://m.9gag.com/ on my Pixel 3 device.

This appears to be a dupe of Bug 1542440.

Status: NEW → RESOLVED
Crash Signature: [@ libart.so@0x46fcc0] [@ libart.so@0x47a8a8] [@ libart.so@0x46f6d8] [@ libart.so@0x4380cc] [@ libart.so@0x4645d8] [@ libart.so@0x4657f4] [@ libart.so@0x437450] [@ libart.so@0x464528] [@ libart.so@0x456cac] [@ libart.so@0x35ce9b] → [@ libart.so@0x46fcc0] [@ libart.so@0x47a8a8] [@ libart.so@0x46f6d8] [@ libart.so@0x4380cc] [@ libart.so@0x4645d8] [@ libart.so@0x4657f4] [@ libart.so@0x437450] [@ libart.so@0x464528] [@ libart.so@0x456cac] [@ libart.so@0x35ce9b] [@ mozilla::jav…
Closed: 4 months ago
Flags: needinfo?(mirabela.lobontiu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1542440
You need to log in before you can comment on or make changes to this bug.