Closed Bug 1542848 Opened 5 months ago Closed 5 months ago

Browser Console is broken with error "Minified React error #31"

Categories

(DevTools :: Console, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Felipe, Unassigned)

References

(Regression)

Details

My Browser Console is broken as of a couple of Nightlies ago, with this error:

JavaScript error: resource://devtools/client/shared/vendor/react-dom.js, line 33: Error: Minified React error #31; visit https://reactjs.org/docs/error-decoder.html?invariant=31&args[]=object%20with%20keys%20%7Btype%2C%20initial%2C%20length%2C%20actor%7D&args[]= for the full message or use the non-minified dev environment for full errors and additional helpful warnings.

This error doesn't reproduce on a clean profile, so it seems that some settings on my profile are needed to trigger it.

I tried to bisect it using mozregression and something very weird happens..

I used the clone-first option to clone my profile to reproduce the error, and set 2019-03-01 as the good date, and 2019-04-08 as the bad date. The original good and bad verification works, but once the profile has gotten in the bad state once, it always remain broken, even when going back on older builds.

The remote agent that landed in bug 1523104 is not enabled in default
builds, meaning you must pass ac_add_options --enable-cdp to
include it in the build. I’m having a hard time understanding what
changed that could cause the Browser Console to break.

Thanks for the bug report Felipe.

:ato, the patch probably triggers and underlying bug in the console. Does the --enable-cdp work with artifact builds?

The unminified error is:

Objects are not valid as a React child (found: object with keys {type, initial, length, actor}).

The object shape ({type, initial, length, actor}) makes me think the console try to display a string, but is in fact dealing with a long string (i.e. a string with more than 9999 chars). Felipe, do you see a very long error message in the terminal or something? Also, do you have a stacktrace with the error? I'd be able to identify the cause of the bug more easily if you do. Thanks!

Flags: needinfo?(felipc)

(In reply to Nicolas Chevobbe from comment #4)

:ato, the patch probably triggers and underlying bug in the
console. Does the --enable-cdp work with artifact builds?

It should do, yes.

Let me know if there’s anything I can help out with here.

It is working again for some reason... If the problem returns I'll try to get more info.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(felipc)
Resolution: --- → WORKSFORME

the error is probably still here, but only gets triggered when we are trying to log a specific message.

You need to log in before you can comment on or make changes to this bug.