Turn on block autoplay in 67

RESOLVED FIXED in Firefox 67

Status

()

defect
P1
major
RESOLVED FIXED
3 months ago
2 months ago

People

(Reporter: drno, Assigned: alwu)

Tracking

({dev-doc-complete, site-compat})

unspecified
mozilla68
Points:
---

Firefox Tracking Flags

(firefox67blocking fixed, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

Block autoplay appears to be off by default in everything except Nightly as per https://searchfox.org/mozilla-central/rev/8d78f219702286c873860f39f9ed78bad1a6d062/browser/app/profile/firefox.js#1491

As we have successfully rolled out the feature via Normandy in 66, we should turn the feature on in >= 67 to not have to rely on Normandy going forward any more.

Assignee

Comment 1

3 months ago

As we have successfully rolled out the feature via Normandy in 66, we should turn the feature on in >= 67 to not have to rely on Normandy going forward any more.

Comment 2

3 months ago
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8e1aac075975
turn on block autoplay by default. r=cpearce

Comment 3

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee

Comment 4

3 months ago

Comment on attachment 9056923 [details]
Bug 1542921 - turn on block autoplay by default.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: none
  • User impact if declined: Will not be able to have block autoplay by default
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a pref-flip patch, it doesn't any functional change. In addition, we have enabled this feature on 66 via Normandy.
  • String changes made/needed: none
Attachment #9056923 - Flags: approval-mozilla-beta?

Comment on attachment 9056923 [details]
Bug 1542921 - turn on block autoplay by default.

Low risk, approved for 67 beta 10, thanks.

Attachment #9056923 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

I've added a release note to https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Releases/67#APIs to document this. Let me know if this looks OK.

Assignee

Comment 8

2 months ago

Hi, Chris,
I would prefer not to mention it, because actually we've enabled this feature on 66 via Normandy. What we do here now is just to ensure that no one will miss this feature on 67.
Thank you.

Flags: needinfo?(cmills)

(In reply to Alastor Wu [:alwu] from comment #8)

Hi, Chris,
I would prefer not to mention it, because actually we've enabled this feature on 66 via Normandy. What we do here now is just to ensure that no one will miss this feature on 67.
Thank you.

OK, makes sense to me; we do mention it in the Fx66 rel notes already.

I've removed it now.

Flags: needinfo?(cmills)
You need to log in before you can comment on or make changes to this bug.