Closed Bug 1542975 Opened 2 years ago Closed 10 months ago

Radio buttons in Forget panel are not keyboard navigable

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Firefox 74
Tracking Status
firefox74 --- fixed

People

(Reporter: Jamie, Assigned: u7693, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [lang=js])

Attachments

(1 file)

STR:

  1. Add the Forget button to the toolbar.
  2. Press the Forget button.
  3. Try to get to the timespan radio buttons with the keyboard (tab or up/down arrow keys).
    • Expected: You should be able to get to them with the tab key at least.
    • Actual: They are not reachable with either the tab key or the up and down arrow keys.

The tab key should definitely reach the radiogroup.

The behaviour regarding the up/down arrow keys is less clear. They're sort of like buttons, but the problem is that up/down arrow keys do normally adjust the value like they would in a menulist. We don't want users accidentally adjusting the value as they try to navigate, but nor do we want users being confused by the inability to adjust the value when they do want to adjust it.

Given this, I think we should treat radiogroups like we do menulists; i.e. they should be reachable with tab only and up/down arrow keys should be passed through when the control is focused.

Priority: -- → P3
  1. Add radiogroup to the list of elements that is navigable with tab only in PanelMultiView:
    https://searchfox.org/mozilla-central/rev/597a69c70a5cce6f42f159eb54ad1ef6745f5432/browser/components/customizableui/PanelMultiView.jsm#1511
  2. Verify that you can get to the timespan radiogroup in the Forget panel with the tab key and that up/down arrows adjust the selected option.
  3. Adjust the browser_PanelMultiView_keyboard.js test so that it tests that radiogroup is skipped in testDownArrow and testUpArrow, and add a test case similar to testArrowsMenulist for radiogroup:
    https://searchfox.org/mozilla-central/source/browser/components/customizableui/test/browser_PanelMultiView_keyboard.js
Mentor: jteh
Whiteboard: [lang=js]
Assignee: nobody → u7693
Status: NEW → ASSIGNED
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ec1603a7410
Radio buttons in Forget panel are not keyboard navigable r=Jamie
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
You need to log in before you can comment on or make changes to this bug.