Most customizable items (looks like all API-based widgets) go AWOL after using Forget button

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
Last month

People

(Reporter: maria_berlinger, Assigned: Gijs)

Tracking

Trunk
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox66 wontfix, firefox67 wontfix, firefox68 verified)

Details

Attachments

(1 attachment)

Affected versions

  • 68.0a1(2019-04-09)
  • 67.0b9
  • 66.0.2

Affected platforms

  • mac OS 10.13.6
  • Windows 7x64
  • Windows 10x64
  • Ubuntu 18.04x64

Steps to reproduce

  1. Launch Firefox
  2. Go to customize
  3. Move all items in overflow menu
  4. Click "Restore defaults" button
  5. Drag "Forget" item in toolbar
  6. Click the Forget item then the "Forget" button
  7. Go to customize

Expected result

  • All items are displayed.

Actual result

  • Just 6 items are displayed

Regression range

  • This is not a recent regression since I was able to reproduce it on Firefox 65.0. I'll investigate asap.

Additional notes

  • After refreshing the Firefox all items are displayed

A regression window would be very helpful here.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(maria.berlinger)
Priority: -- → P1
Summary: Customize items aren't all displayed after using Forget button → Most customizable items (looks like all API-based widgets) go AWOL after using Forget button

It looks like just moving 1 API-based widget, like the zoom controls, instead of all of them, and otherwise following the same steps as comment #0, makes that specific widget disappear.

Also, just closing the initial window and opening another one does the same job (on mac, where the process stays live in that case).

This issue is not a regression since I was able to reproduce it on Firefox from 2014-09-29 when the "Forget" button was first implemented.

Flags: needinfo?(maria.berlinger)

This is caused by https://searchfox.org/mozilla-central/rev/d143f8ce30d1bcfee7a1227c27bf876a85f8cede/browser/components/customizableui/CustomizableUI.jsm#1880-1889 ignoring widgets with a currentArea defined, and the fact that currentArea is not updated for API-based widgets when resetting. We don't normally notice this when widgets have already been defined in the same window, but this means a simpler set of STR is:

  1. open firefox
  2. open customize mode
  3. move developer button to a toolbar or the panel
  4. click 'restore defaults'
  5. close customize mode
  6. open a new window
  7. open customize mode in the new window

ER:
developer button is present in customize mode

AR:
it isn't.

This is a bit of an edgecase and easy to workaround, and doesn't affect anything outside of customize mode, so I'm wontfixing for 67 because this code is... complex.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a0006c759073
fix buttons disappearing in customize mode after using 'restore defaults', r=jaws
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Flags: qe-verify+

This issue is verified fixed using Firefox 68.0b9 on the following OSes: Windows 10x64, Windows 7x64, Ubuntu 18.04x64, mac OS 10.13.6.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.