Add plumbing to enable WebRender on qualified Linux devices

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P3
normal
RESOLVED FIXED
15 days ago
5 hours ago

People

(Reporter: aosmond, Assigned: aosmond)

Tracking

(Blocks 2 bugs, Regressed 1 bug)

Trunk
mozilla68
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 days ago

We want to add plumbing to allow for WebRender experiments with our Linux using population. This change is intended to allow it on qualified Intel devices only and with screens that are not too big.

(Assignee)

Updated

15 days ago
Assignee: nobody → aosmond
Blocks: wr-linux
Status: NEW → ASSIGNED
Priority: -- → P3
(Assignee)

Comment 1

15 days ago

Linux machines using Intel graphics with Mesa drivers being at least
18.2.8.0 and not 4k displays should be able to run WebRender well, given
this is a common configuration used for testing already by Mozilla. This
patch allows users meeting said requirements to join the WebRender
experiments on nightly. WebRender will remain disabled by default for
other configurations/devices.

(Assignee)

Comment 3

14 days ago

Minor fix to correct the debug assertion (switched from DisableByDefault to just plain Disable).

try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=c13542523f4795fa4dd0471abe10674950fc6293

Comment 4

14 days ago
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/34e912d9305a
Allow qualified Linux machines to get WebRender. r=jrmuizel
(Assignee)

Comment 6

14 days ago

Looks like I have to check to see if HW_COMPOSITING was disabled by the runtime due to safe mode / headless before trying to disable it due to environment.

Flags: needinfo?(aosmond)

Comment 7

14 days ago
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3fcf307ee80
Allow qualified Linux machines to get WebRender. r=jrmuizel

Comment 8

14 days ago
bugherder
Status: ASSIGNED → RESOLVED
Last Resolved: 14 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Updated

11 days ago
Depends on: 1544183
No longer depends on: 1544183
Regressions: 1544183
You need to log in before you can comment on or make changes to this bug.