Closed Bug 1543234 Opened 1 year ago Closed 3 months ago

Emulation front shows error "this.targetActor.docShell is null" when closing RDM.

Categories

(DevTools :: Responsive Design Mode, defect, P3)

65 Branch
defect

Tracking

(firefox72 fixed)

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: mtigley, Assigned: mtigley)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This is caused by the emulation actor instantiated in RDM calling stopPrintMediaSimulation in its destroy method. By the time stopEmulatingMedium is called, the targetActor is already null. This is highlighting an issue where RDM creates its own Emulation Actor and as a result, is calling print simulation methods when RDM closes and cleans up its actors even though print simulation itself isn't enabled in RDM, but from the toolbox instead.

A quick fix would be to only call stopPrintMediaSimulation in destroy if the member variable _printSimulationEnabled is true. We know right now that RDM's version of this EmulationActor will never have _printSimulationEnabled true since it never toggles it on, to begin with. Other options are to have the client responsible for calling stopPrintMediaSimulation when needed, or to move print simulation into its own actor.

Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/31c4e1a34b78
Only call stopPrintMediaSimulation in destroy() if print simulation is enabled r=gl
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
You need to log in before you can comment on or make changes to this bug.