Crash in [@ mozilla::dom::BrowsingContextGroup::Select]

RESOLVED DUPLICATE of bug 1543015

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1543015
2 months ago
a month ago

People

(Reporter: lizzard, Unassigned)

Tracking

({crash, regression})

68 Branch
Desktop
All
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

(crash signature)

This bug is for crash report bp-4cc9349d-e019-4b93-994e-6e7d10190409.

First seen in the 20190408193006 build.

Top 10 frames of crashing thread:

0 libxul.so mozilla::dom::BrowsingContextGroup::Select docshell/base/BrowsingContextGroup.h:78
1 libxul.so mozilla::dom::ContentChild::RecvAttachBrowsingContext dom/ipc/ContentChild.cpp:3773
2 libxul.so mozilla::dom::PContentChild::OnMessageReceived ipc/ipdl/PContentChild.cpp:10858
3 libxul.so mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2151
4 libxul.so mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1937
5 libxul.so nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1180
6 libxul.so NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:486
7 libxul.so mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:88
8 libxul.so MessageLoop::Run ipc/chromium/src/base/message_loop.cc:315
9 libxul.so nsBaseAppShell::Run widget/nsBaseAppShell.cpp:137

These all crash with "MOZ_RELEASE_ASSERT(parent || aParentId == 0)". Likely related to (or duplicate of) bug 1543015?

See Also: → 1543015
OS: Linux → All
Hardware: Unspecified → Desktop

This seems to be fixed.

Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
See Also: 1543015
Version: 66 Branch → 68 Branch
Duplicate of bug: 1543015
You need to log in before you can comment on or make changes to this bug.