Bookmarks parser adding spaces to long bookmarks

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Suresh Duddi (gone), Assigned: Robert John Churchill)

Tracking

Trunk
Other
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Here is my query for my M11 bugs for our group. A space seems to have
 gotten added. Look at "&emailassigned_t o1=1&email2" The space
 inbetween the "t" and "o1" is the problem. This was ok the first time
 it got migrated. So I suspect this happened in our routine to write
 bookmarks out.
 <DT><A
HREF="http://bugzilla.mozilla.org/buglist.cgi?target_milestone=M11&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=%5E%28dp%7Cneeti%7Crjc%7Cwaterson%7Cmorse%7Cpnunn%7Cspence%7Cebina%29&emailtype1=regexp&emailassigned_t
o1=1&email2=&emailtype2=substring&emailreporter2=1&changedin=&short_desc=&short_desc_type=substr&long_desc=&long_desc_type=substr&bug_file_loc=&bug_file_loc_type=substr&status_whiteboard=&status_whiteboard_type=substr&newqueryname=&form_name=query&order=a
ssign.login_name%2C%20assign.login_name%2C%20bugs.priority%2C%20bugs.bug_severity"
ADD_DATE="926790687" LAST_VISIT="939002554" LAST_MODIFIED="926790661">M11</A>

The right bookmark is:
<DT><A
HREF="http://bugzilla.mozilla.org/buglist.cgi?target_milestone=M11&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&email1=%5E%28dp%7Cneeti%7Crjc%7Cwaterson%7Cmorse%7Cpnunn%7Cspence%7Cebina%29&emailtype1=regexp&emailassigned_to1=1&email2=&emailtype2=substring&emailreporter2=1&changedin=&short_desc=&short_desc_type=substr&long_desc=&long_desc_type=substr&bug_file_loc=&bug_file_loc_type=substr&status_whiteboard=&status_whiteboard_type=substr&newqueryname=&form_name=query&order=assign.login_name%2C%20assign.login_name%2C%20bugs.priority%2C%20bugs.bug_severity"
ADD_DATE="926790687" LAST_VISIT="938817236" LAST_MODIFIED="926790661">M11</A>

The above happened to every bookmark like this... I have M10, M11, M12
bookmarks.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

19 years ago
Its a problem with reading in bookmarks on a long line that causes buffer

overflow (byte # 256 currently, as our buffers are 256 bytes) where the UTF-8

conversion takes the trailing 0x00 byte and changes it to a space.



I have a fix. DP, want to review it for me?
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 2

19 years ago
Adding verifyme keyword.
Keywords: verifyme

Comment 3

19 years ago
dp, so what is the specific testcase to verify?
Component: Browser-General → Bookmarks
QA Contact: leger → claudius

Updated

19 years ago
Whiteboard: waiting for testcase

Comment 4

18 years ago
so robert, is it sufficient to bookmark "the right bookmark" dp lists in 4.x and then migrate the profile containing that bookmark 
to seamonkey and then visually inspect that the url contians no spaces in the properties dialog?
(Assignee)

Comment 5

18 years ago
Yeah, think so.

Updated

18 years ago
Whiteboard: waiting for testcase
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.