Closed Bug 1543634 Opened 2 years ago Closed 1 year ago

Intermittent browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Found a browser window after previous test timed out - | Test timed out

Categories

(Firefox :: Protections UI, defect, P5)

defect

Tracking

()

RESOLVED FIXED
Firefox 73
Fission Milestone M4.1
Tracking Status
firefox73 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nhnt11)

References

(Blocks 3 open bugs)

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell unknown])

Attachments

(1 file)

#[markdown(off)]
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=239600613&repo=autoland

https://queue.taskcluster.net/v1/task/A1ZIhlQCR0GaB-n9JCY04Q/runs/0/artifacts/public/logs/live_backing.log

09:14:30 INFO - TEST-START | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js
09:14:30 INFO - GECKO(1040) | JavaScript warning: chrome://global/content/bindings/tabbox.xml, line 162: Array.forEach is deprecated; use Array.prototype.forEach instead
09:14:30 INFO - GECKO(1040) | JavaScript warning: chrome://browser/content/browser-ctrlTab.js, line 568: Array.filter is deprecated; use Array.prototype.filter instead

09:15:15 INFO - Buffered messages logged at 09:14:32
09:15:15 INFO - Console message: [JavaScript Warning: "Array.filter is deprecated; use Array.prototype.filter instead" {file: "chrome://browser/content/browser-ctrlTab.js" line: 568}]
09:15:15 INFO - Console message: [JavaScript Warning: "Array.indexOf is deprecated; use Array.prototype.indexOf instead" {file: "chrome://global/content/bindings/tabbox.xml" line: 258}]
09:15:15 INFO - Buffered messages finished
09:15:15 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Test timed out -
09:15:15 INFO - GECKO(1040) | MEMORY STAT | vsize 4582MB | residentFast 394MB | heapAllocated 124MB
09:15:15 INFO - TEST-OK | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | took 45045ms
09:15:15 INFO - checking window state
09:15:15 INFO - Not taking screenshot here: see the one that was previously logged
09:15:15 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Found a browser window after previous test timed out -
09:15:15 INFO - GECKO(1040) | must wait for focus
09:15:15 INFO - TEST-START | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js
09:15:22 INFO - GECKO(1040) | MEMORY STAT | vsize 5308MB | residentFast 400MB | heapAllocated 135MB
09:15:22 INFO - TEST-OK | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | took 7302ms

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

This bug has been observed on macosx1014-64-shippable/opt at a low frequency.

Blocks: 1530474
Keywords: regression
Summary: Intermittent browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Found a browser window after previous test timed out - → Intermittent browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Found a browser window after previous test timed out - | Test timed out
Duplicate of this bug: 1587505
Fission Milestone: --- → M4.1

Clearing needinfo for now. I'll be looking at all of the trackingUI tests once unblocked by etp-fission.

Flags: needinfo?(nhnt11)

There are 20 total failures in the last 7 days on linux64-shippable, macosx1014-64-shippable and few on windows10-64-shippable-qr opt.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=278382244&repo=autoland&lineNumber=5478

[task 2019-11-27T10:41:19.790Z] 10:41:19 INFO - TEST-START | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js
[task 2019-11-27T10:41:20.034Z] 10:41:20 INFO - GECKO(4136) | about:privatebrowsing
[task 2019-11-27T10:41:20.194Z] 10:41:20 INFO - GECKO(4136) | about:privatebrowsing
[task 2019-11-27T10:41:20.195Z] 10:41:20 INFO - GECKO(4136) | about:privatebrowsing
[task 2019-11-27T10:41:20.277Z] 10:41:20 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:41:20.287Z] 10:41:20 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:41:20.287Z] 10:41:20 INFO - GECKO(4136) | Waiting for browser load
[task 2019-11-27T10:41:20.316Z] 10:41:20 INFO - GECKO(4136) | Saw state c0010 and status 0
[task 2019-11-27T10:41:20.316Z] 10:41:20 INFO - GECKO(4136) | Browser loaded about:blank
[task 2019-11-27T10:41:20.347Z] 10:41:20 INFO - GECKO(4136) | about:privatebrowsing
[task 2019-11-27T10:41:20.370Z] 10:41:20 INFO - GECKO(4136) | about:privatebrowsing
[task 2019-11-27T10:41:20.584Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.584Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.603Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: currentRemoteType (web) preferredRemoteType: web
[task 2019-11-27T10:41:20.603Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.603Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: web, web, false
[task 2019-11-27T10:41:20.603Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: type (web) is compatible - ignoring
[task 2019-11-27T10:41:20.633Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: remote subframes disabled - ignoring
[task 2019-11-27T10:41:20.643Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.661Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: currentRemoteType (web) preferredRemoteType: web
[task 2019-11-27T10:41:20.662Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.662Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: web, web, false
[task 2019-11-27T10:41:20.662Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: type (web) is compatible - ignoring
[task 2019-11-27T10:41:20.700Z] 10:41:20 INFO - GECKO(4136) | [process-switch]: remote subframes disabled - ignoring
[task 2019-11-27T10:41:20.720Z] 10:41:20 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:41:20.739Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.740Z] 10:41:20 INFO - GECKO(4136) | http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html
[task 2019-11-27T10:41:20.740Z] 10:41:20 INFO - GECKO(4136) | about:blank

task 2019-11-27T10:42:04.891Z] 10:42:04 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | correct tooltip -
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | icon box is visible -
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - Leaving test bound testExceptionAddition
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - Entering test bound testExceptionPersistence
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - Open another private browsing window
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - Buffered messages finished
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Test timed out -
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - GECKO(4136) | MEMORY STAT | vsize 2104167MB | vsizeMaxContiguous 65651349MB | residentFast 293MB | heapAllocated 105MB
[task 2019-11-27T10:42:04.892Z] 10:42:04 INFO - TEST-OK | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | took 45083ms
[task 2019-11-27T10:42:04.893Z] 10:42:04 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:42:04.893Z] 10:42:04 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:42:04.893Z] 10:42:04 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:42:04.894Z] 10:42:04 INFO - GECKO(4136) | about:blank
[task 2019-11-27T10:42:04.894Z] 10:42:04 INFO - checking window state
[task 2019-11-27T10:42:04.894Z] 10:42:04 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-11-27T10:42:04.894Z] 10:42:04 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_pbmode_exceptions.js | Found a browser window after previous test timed out -
[task 2019-11-27T10:42:04.894Z] 10:42:04 INFO - GECKO(4136) | must wait for focus

Nihanth are there any updates here?

Whiteboard: [stockwell needswork:owner]

etp-fission seems like it's going to take a while so maybe we shouldn't wait to look at this. I don't have time this week though.

Whiteboard: [stockwell unknown] → [stockwell needswork:owner]

Wanted to chime in that I'm observing this on non-fission on the ubuntu1804 test image. I believe this only started recently - my greening push from November 28 does not have this failure.

To run against ubuntu1804 on try, use ./mach try fuzzy --ubuntu-bionic and select the linux jobs as normal.

Nihanth hi, did you have time to look?

Flags: needinfo?(nhnt11)
Assignee: nobody → nhnt11
Status: REOPENED → ASSIGNED
Flags: needinfo?(nhnt11)
Pushed by nhnt11@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a34b7b4c3b0b
Don't wait for STATE_STOP when adding new blank tabs in browser_trackingUI_pbmode_exceptions.js. r=ewright
Status: ASSIGNED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
You need to log in before you can comment on or make changes to this bug.