Closed Bug 1543741 Opened 8 months ago Closed 8 months ago

Blocklist requests getting filed as 'defect' instead of 'task' because of custom form

Categories

(bugzilla.mozilla.org :: Custom Bug Entry Forms, defect)

Production
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: emceeaich, Assigned: kohei)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Despite default type of Toolkit::Blocklist Request bugs being task, new bugs which come through a custom form have a type of defect.

Short term fix would be to update the blocklist request form.

https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/template/en/default/bug/create/create-blocklist.html.tmpl

Long term fix would be to enable templates (and default values) at component level.

Umm, we already have the per-component type. Will figure out why it’s not working.

Assignee: nobody → kohei.yoshino
Status: NEW → ASSIGNED

The issue is here: Bug.pm#L903-L904

$params->{bug_type} = Bugzilla->params->{default_bug_type}
  unless defined $params->{bug_type};

The check order should be:

  1. user-defined type
  2. component-specific type
  3. product-specific type (Bug 1541617)
  4. global type = defect
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.