right-clicking on link puts it into :focus state forever

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
19 years ago
10 years ago

People

(Reporter: dbaron, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
DESCRIPTION:  Right-clicking on a link puts it permanently into a state that
matches ":hover" in CSS.

STEPS TO REPRODUCE:
* Load http://www.fas.harvard.edu/~dbaron/
* Right click on a link

ACTUAL RESULTS:  The link's background changes to maroon, and it stays that way.

EXPECTED RESULTS:  The link's background should only be maroon while the mouse
pointer is over the link.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-03-08-M11
(Reporter)

Updated

19 years ago
Assignee: don → trudelle
Component: Browser-General → XP Toolkit/Widgets
(Reporter)

Comment 1

19 years ago
Changing component to "XP Toolkit/Widgets" since this has to do with context
menus and I think that's the right place...

Updated

19 years ago
Assignee: trudelle → saari
Target Milestone: M15

Comment 2

19 years ago
reassigning to saari as p3 for m15

Updated

19 years ago
QA Contact: leger → elig

Comment 3

19 years ago
[Contextual menu bug --- QA Assigning to self.]
(Reporter)

Updated

19 years ago
Summary: right-clicking on link puts it into :hover state forever → right-clicking on link puts it into :focus state forever
(Reporter)

Comment 4

19 years ago
It's actually the :focus state, not the :hover state (the :focus and :hover
colors on the given page are the same - I quickly changed one of them to test).
Component: XP Toolkit/Widgets → XPMenus
QA Contact: elig → sairuh
reassign QA contact to me & updated component.
(Reporter)

Comment 6

19 years ago
I think this is either fixed or it's a duplicate of bug 21363.
(Reporter)

Comment 7

19 years ago
But right clicking on a link does put it into :focus.  Should it?

Comment 8

19 years ago
BULK MOVE: Changing component from XP Menus to XP Toolkit/Widgets: Menus.  XP 
Menus component will be deleted.
Component: XPMenus → XP Toolkit/Widgets: Menus

Comment 9

19 years ago
Pink, I think this is actually the bug with mouse events going to the parent
window instead of the popup.
Assignee: saari → pinkerton
Target Milestone: M15
(Assignee)

Comment 10

19 years ago
no, it has nothing to do with parent/child as far as i can tell. it's also XP, 
though the mac seems to make the link active as well while the other platforms 
don't.
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 11

19 years ago
post beta
Target Milestone: M16
(Assignee)

Comment 12

18 years ago
moving all defects not directly related to P0 beta2 features off to M18.
Target Milestone: M16 → M18

Comment 13

18 years ago
Mass moving M18 bugs to M19
Target Milestone: M18 → M19

Comment 14

18 years ago
mass-moving all bugs to m21 that are not dogfood+ or nsbeta2+ or nsbeta2-
Target Milestone: M19 → M21
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
(Assignee)

Comment 16

18 years ago
futuring. it's easy to get out of this state, and mostly harmless.
Target Milestone: M21 → Future
(Assignee)

Comment 17

18 years ago
i suspect this is because we eat the event that dismisses the popup and don't
let it through to gecko. As a result, the click to take it out of the focus
state never gets through. Is this that bad? *shrug*
(Reporter)

Comment 18

18 years ago
As noted in the 7-25 comment above, this bug is less serious than it was when it
was originally filed.

Comment 19

18 years ago
I think this should be wontfix, because removing focus from the link (and 
putting it where?) would make it impossible to focus a link using the mouse.  
In IE, I can right-click a link and then click on the title bar to give the 
link focus.

What's the bug number for eating clicks that dismiss context menus?

Comment 20

18 years ago
Hmm, maybe I misinterpreted the bug.  I'm still confused about what the current 
problem is.

Comment 21

17 years ago
Ok, I guess the question is whether a left-click that cancels a context menu 
should move focus.  I say it shouldn't, because it would be confusing to move 
focus without also activating the element clicked on.

See bug 21390 for a discussion of whether a click cancelling a menu should "go 
through".
(Reporter)

Comment 22

17 years ago
Agreed.  The originally reported bug is fixed, and maybe there's nothing else to
do here.

Comment 23

17 years ago
Ok, wfm then.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.