Closed Bug 1544267 Opened 8 months ago Closed 7 months ago

html file input element does not work to capture photo from camera

Categories

(Firefox for Android :: General, defect, P1)

Firefox 66
ARM
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1511839
Tracking Status
firefox66 --- affected
firefox67 --- affected
firefox68 --- affected

People

(Reporter: jmb, Assigned: petru)

References

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

On any website containing a file input element <input type="file" accept="image/*"> firefox will trigger android to either select a picture from the device's storage or a new captured photo from the camera.

Actual results:

While it is possible to select any picture from the device's storage, it is not possible to capture a new photo. The camera is activated, but the photo can not be confirmed. After taking a picture, the android camera shows three icons: "repeat", "cancel" and "accept". While "repeat" and "cancel" work as intended, "accept" does not do anything.

Expected results:

The newly captured photo should be selectable as new image file for the html input element.

Hello,

Can you please specify the model of the device and firmware that you are using and the websites that you are having issues with?

Thank you

Flags: needinfo?(jmb)
Component: General → Logins, Passwords and Form Fill
OS: Unspecified → Android
Hardware: Unspecified → ARM

The issue was found using Android 8, Android 8.1 and Android 9 devices. It happened with websites using an <input type="file" accept="image/*"> or even just <input type="file"> element. Just try it here: https://wiki.selfhtml.org/extensions/Selfhtml/example.php/Beispiel:HTML_input-Element10.html

Flags: needinfo?(jmb)

This is not formfill. That is for usernames/passwords and autocomplete in forms.

Component: Logins, Passwords and Form Fill → General
See Also: → 1511839
Priority: -- → P1

Hi,

Thank you for reporting the issue.

I managed to reproduce the bug, after taking the picture, the input element remains with "No file selected".

Environment
Device: Samsung Galaxy S9, Android(8.0.0)
Builds: Firefox Nightly 68.0a1(2019-04-15), Beta 67.0b11 and Release 66.0.2

The bug is possible to be the same with bug 1511839.

I will mark the issue as NEW.

Thank you,
Diana

Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED

Indeed, based on comment #4 and my investigations this seems to be the same issue as the one already reported in bug 1511839.
Will mark this as DUPLICATE. Let's continue in the other ticket.

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1511839
You need to log in before you can comment on or make changes to this bug.