Closed Bug 1544757 Opened 1 year ago Closed 5 months ago

Failed assertion MOZ_ASSERT(mRaceCacheWithNetwork || !(mTransactionPump && mCachePump) || mCachedContentIsParMOZ_ASSERT(mRaceCacheWithNetwork || !(mTransactiontial, "If we have both pumps, the cache content must be partial");

Categories

(Core :: Networking: HTTP, defect, P2)

68 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla70
Fission Milestone M5
Tracking Status
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- fixed

People

(Reporter: dragana, Assigned: michal)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [necko-triaged])

Attachments

(2 files, 1 obsolete file)

I notice this assertion failure in nsHttpChannel:

MOZ_ASSERT(mRaceCacheWithNetwork || !(mTransactionPump && mCachePump) ||
mCachedContentIsPartial,
"If we have both pumps, the cache content must be partial");

I've got this assertion with D36301 with enabling fission.autostart when I click "Treeherder Jobs" image in a mail from Taskcluster on mail.google.com.

Fission Milestone: --- → ?

This is what I'm doing and this reproduce very consistently.

  1. Build gecko
  2. ./mach clobber
  3. ./mach run
  4. go to about:config, enable fission
  5. quit
  6. ./mach run
  7. go to cnn.com ; wait for the page to load
  8. quit elegantly (ctrl-shift-q)
  9. ./mach run

This will assert once the session is restored about 80% of the time

This assertion happens on reddit.com during scrolling the contents by wheel scroll. Just before the assertion happens I see
NS_ENSURE_TRUE(mSuspendCount > 0) failed.

Fission Milestone: ? → M5

This is the most common assertions encountered when I have fission enabled

Assignee: nobody → michal.novotny

I cannot reproduce it. If you can reproduce it consistently, could you please provide HTTP log? See https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

Flags: needinfo?(jyavenard)

I can still see the assertion with the way I mentioned in comment 1. I also see the warning in comment 3 at that time.

:hiro, could you please provide HTTP logs for the assertion? Thanks!

Flags: needinfo?(hikezoe.birchill)
Attached file log.zip (obsolete) —

Here, it's a log when I clicked the "Treeherder Jobs" image in a message on gmail.com. I wonder why other people can't reproduce this assertion. It's pretty easy to reproduce for me.

Flags: needinfo?(hikezoe.birchill)

(In reply to Hiroyuki Ikezoe (:hiro) from comment #8)

Here, it's a log when I clicked the "Treeherder Jobs" image in a message on gmail.com.

Thanks for the log. Unfortunately, the log doesn't contain information just before the assertion. Can you please add "sync" keyword to the list of logging modules?
https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging#Use_'sync'_if_your_browser_crashes_or_hangs

I wonder why other people can't reproduce this assertion. It's pretty easy to reproduce for me.

Racing is sensitive to exact timing and I guess my HW setup doesn't trigger this assertion.

Flags: needinfo?(jyavenard) → needinfo?(hikezoe.birchill)
Attached file A log with sync flag
Attachment #9084440 - Attachment is obsolete: true
Flags: needinfo?(hikezoe.birchill)

When revalidated cache entry is used, normally the sequence is:
OnStartRequest(mTransactionPump)
OnStopRequest(mTransactionPump)
OnStartRequest(mCachePump)
OnStopRequest(mCachePump)

When doing cross process redirect, the call to OnStopRequest(mTransactionPump) might get delayed, so we can still have mTransactionPump in OnStartRequest(mCachePump).

Pushed by mnovotny@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3feee5147ab0
Failed assertion MOZ_ASSERT(mRaceCacheWithNetwork || !(mTransactionPump && mCachePump) || mCachedContentIsPartial), r=mayhemer
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/836eaf6f89c1
Failed assertion MOZ_ASSERT(mRaceCacheWithNetwork || !(mTransactionPump && mCachePump) || mCachedContentIsPartial), r=mayhemer

This push was not the cause for for the dt perma failures on browser_parsable_css.js

Flags: needinfo?(michal.novotny)
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla70

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Duplicate of this bug: 1573099
You need to log in before you can comment on or make changes to this bug.