Closed Bug 1544818 Opened 3 years ago Closed 3 years ago

Crash in [@ mozilla::PresShell::ContentStateChanged]

Categories

(Core :: Layout, defect)

67 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1530190
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- fix-optional
firefox68 --- fix-optional

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-57e43d96-fe89-4348-a438-143ad0190416.

Top 10 frames of crashing thread:

0 xul.dll void mozilla::PresShell::ContentStateChanged layout/base/PresShell.cpp:4226
1 xul.dll mozilla::dom::Document::ContentStateChanged dom/base/Document.cpp:4963
2 xul.dll mozilla::dom::Element::RemoveStates dom/base/Element.h:629
3 xul.dll bool nsFocusManager::Blur dom/base/nsFocusManager.cpp:1598
4 xul.dll nsFocusManager::WindowLowered dom/base/nsFocusManager.cpp:749
5 xul.dll void nsWebShellWindow::WindowDeactivated xpfe/appshell/nsWebShellWindow.cpp:470
6 xul.dll void nsWebShellWindow::WidgetListenerDelegate::WindowDeactivated xpfe/appshell/nsWebShellWindow.cpp:810
7 xul.dll bool nsWindow::ProcessMessage widget/windows/nsWindow.cpp:5715
8 xul.dll static long nsWindow::WindowProcInternal widget/windows/nsWindow.cpp:4750
9 xul.dll CallWindowProcCrashProtected xpcom/base/nsCrashOnException.cpp:27

crash reports with this signature are starting to appear cross-platform in firefox 67 in low to mid-volume - nearly all of them show MOZ_RELEASE_ASSERT(!mInStyleRefresh).

a couple of comments report they where in about:preferences when the crash occurred...

Flags: needinfo?(emilio)

Yeah, this is bug 1530190.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(emilio)
Resolution: --- → DUPLICATE
Duplicate of bug: 1530190

(Sorry, should've looked harder at the stacks before making you file a new bug :/)

no worries, bugs are cheap ;-)

You need to log in before you can comment on or make changes to this bug.