Intermittent dom/media/tests/mochitest/| <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] after application terminated with exit code 11

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
critical
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: intermittent-bug-filer, Assigned: dminor)

Tracking

(Regression, {crash, intermittent-failure, regression})

unspecified
mozilla69
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox67 unaffected, firefox68 fixed, firefox69 fixed)

Details

(Whiteboard: [stockwell disable-recommended], crash signature)

Attachments

(1 attachment)

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=241026968&repo=autoland

https://queue.taskcluster.net/v1/task/DJ-yYNtRR9au3TUcpUpDVQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-04-17T19:16:40.435Z] 19:16:40 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/5e5c3ae4-0280-5f19-1098-d5555119f162.extra
[task 2019-04-17T19:16:40.580Z] 19:16:40 INFO - PROCESS-CRASH | dom/media/tests/mochitest/test_getUserMedia_basicScreenshare.html | application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()]
[task 2019-04-17T19:16:40.580Z] 19:16:40 INFO - Crash dump filename: /tmp/tmpO1BUbd.mozrunner/minidumps/5e5c3ae4-0280-5f19-1098-d5555119f162.dmp
[task 2019-04-17T19:16:40.582Z] 19:16:40 INFO - Operating system: Linux
[task 2019-04-17T19:16:40.582Z] 19:16:40 INFO - 0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2019-04-17T19:16:40.583Z] 19:16:40 INFO - CPU: x86
[task 2019-04-17T19:16:40.583Z] 19:16:40 INFO - GenuineIntel family 6 model 62 stepping 4
[task 2019-04-17T19:16:40.585Z] 19:16:40 INFO - 2 CPUs
[task 2019-04-17T19:16:40.585Z] 19:16:40 INFO -
[task 2019-04-17T19:16:40.585Z] 19:16:40 INFO - GPU: UNKNOWN
[task 2019-04-17T19:16:40.585Z] 19:16:40 INFO -
[task 2019-04-17T19:16:40.586Z] 19:16:40 INFO - Crash reason: SIGSEGV /SEGV_MAPERR
[task 2019-04-17T19:16:40.586Z] 19:16:40 INFO - Crash address: 0xe0d00004
[task 2019-04-17T19:16:40.586Z] 19:16:40 INFO - Process uptime: not available
[task 2019-04-17T19:16:40.586Z] 19:16:40 INFO -
[task 2019-04-17T19:16:40.587Z] 19:16:40 INFO - Thread 51 (crashed)
[task 2019-04-17T19:16:40.587Z] 19:16:40 INFO - 0 libxul.so!webrtc::MouseCursorMonitorX11::CaptureCursor() [mouse_cursor_monitor_x11.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 218 + 0x0]
[task 2019-04-17T19:16:40.587Z] 19:16:40 INFO - eip = 0xf080c8b3 esp = 0xdeaa98f0 ebp = 0xdeaa99d8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.588Z] 19:16:40 INFO - esi = 0xe0cff000 edi = 0xe4e4e4e4 eax = 0xe0ce57f4 ecx = 0xe0ce5900
[task 2019-04-17T19:16:40.588Z] 19:16:40 INFO - edx = 0xe0d00004 efl = 0x00010283
[task 2019-04-17T19:16:40.589Z] 19:16:40 INFO - Found by: given as instruction pointer in context
[task 2019-04-17T19:16:40.589Z] 19:16:40 INFO - 1 libxul.so!webrtc::MouseCursorMonitorX11::Init(webrtc::MouseCursorMonitor::Callback*, webrtc::MouseCursorMonitor::Mode) [mouse_cursor_monitor_x11.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 124 + 0x9]
[task 2019-04-17T19:16:40.590Z] 19:16:40 INFO - eip = 0xf080c64a esp = 0xdeaa99e0 ebp = 0xdeaa9ac8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.590Z] 19:16:40 INFO - esi = 0xde4a5460 edi = 0xe0bc8000
[task 2019-04-17T19:16:40.591Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.592Z] 19:16:40 INFO - 2 libxul.so!webrtc::DesktopAndCursorComposer::Start(webrtc::DesktopCapturer::Callback*) [desktop_and_cursor_composer.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 158 + 0xf]
[task 2019-04-17T19:16:40.592Z] 19:16:40 INFO - eip = 0xf0808cce esp = 0xdeaa9ad0 ebp = 0xdeaa9ae8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.593Z] 19:16:40 INFO - esi = 0xde4a5520 edi = 0xde592400
[task 2019-04-17T19:16:40.593Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.594Z] 19:16:40 INFO - 3 libxul.so!webrtc::DesktopCaptureImpl::StartCapture(webrtc::VideoCaptureCapability const&) [desktop_capture_impl.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 617 + 0x12]
[task 2019-04-17T19:16:40.594Z] 19:16:40 INFO - eip = 0xef46eed0 esp = 0xdeaa9af0 ebp = 0xdeaa9b18 ebx = 0xf538e000
[task 2019-04-17T19:16:40.595Z] 19:16:40 INFO - esi = 0xdca74eb0 edi = 0xde592400
[task 2019-04-17T19:16:40.596Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.596Z] 19:16:40 INFO - 4 libxul.so!non-virtual thunk to webrtc::DesktopCaptureImpl::StartCapture(webrtc::VideoCaptureCapability const&) [desktop_capture_impl.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 0 + 0x23]
[task 2019-04-17T19:16:40.597Z] 19:16:40 INFO - eip = 0xef46ef37 esp = 0xdeaa9b20 ebp = 0xdeaa9b38 ebx = 0xf538e000
[task 2019-04-17T19:16:40.597Z] 19:16:40 INFO - esi = 0xde592404 edi = 0xde592404
[task 2019-04-17T19:16:40.598Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.599Z] 19:16:40 INFO - 5 libxul.so!std::_Function_handler<void (mozilla::camera::VideoEngine::CaptureEntry&), mozilla::camera::CamerasParent::RecvStartCapture(mozilla::camera::CaptureEngine const&, int const&, mozilla::camera::VideoCaptureCapability const&)::$_10::operator()() const::{lambda(mozilla::camera::VideoEngine::CaptureEntry&)#1}>::_M_invoke(std::_Any_data const&, mozilla::camera::VideoEngine::CaptureEntry&) [functional:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 1731 + 0x470]
[task 2019-04-17T19:16:40.599Z] 19:16:40 INFO - eip = 0xef4749cf esp = 0xdeaa9b40 ebp = 0xdeaa9bb8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.600Z] 19:16:40 INFO - esi = 0xde592404 edi = 0xde592404
[task 2019-04-17T19:16:40.600Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.601Z] 19:16:40 INFO - 6 libxul.so!mozilla::camera::VideoEngine::WithEntry(int, std::function<void (mozilla::camera::VideoEngine::CaptureEntry&)> const&&) [VideoEngine.cpp:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 252 + 0x13]
[task 2019-04-17T19:16:40.602Z] 19:16:40 INFO - eip = 0xef469cbc esp = 0xdeaa9bc0 ebp = 0xdeaa9be8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.602Z] 19:16:40 INFO - esi = 0xdca2e96c edi = 0xde961904
[task 2019-04-17T19:16:40.602Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.603Z] 19:16:40 INFO - 7 libxul.so!mozilla::media::LambdaRunnable<mozilla::camera::CamerasParent::RecvStartCapture(mozilla::camera::CaptureEngine const&, int const&, mozilla::camera::VideoCaptureCapability const&)::$_10>::Run() [MediaUtils.h:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 73 + 0x16e]
[task 2019-04-17T19:16:40.603Z] 19:16:40 INFO - eip = 0xef4743b0 esp = 0xdeaa9bf0 ebp = 0xdeaa9c48 ebx = 0xf538e000
[task 2019-04-17T19:16:40.604Z] 19:16:40 INFO - esi = 0xdeaa9c20 edi = 0xdb76b550
[task 2019-04-17T19:16:40.604Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.605Z] 19:16:40 INFO - 8 libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 1180 + 0x16]
[task 2019-04-17T19:16:40.605Z] 19:16:40 INFO - eip = 0xed073c0c esp = 0xdeaa9c50 ebp = 0xdeaaa138 ebx = 0xf538e000
[task 2019-04-17T19:16:40.605Z] 19:16:40 INFO - esi = 0xdeaa9cc0 edi = 0xdbdbb400
[task 2019-04-17T19:16:40.606Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.606Z] 19:16:40 INFO - 9 libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 486 + 0x11]
[task 2019-04-17T19:16:40.606Z] 19:16:40 INFO - eip = 0xed0764aa esp = 0xdeaaa140 ebp = 0xdeaaa168 ebx = 0xf538e000
[task 2019-04-17T19:16:40.607Z] 19:16:40 INFO - esi = 0xdeaaa15b edi = 0xdeaaa248
[task 2019-04-17T19:16:40.608Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.609Z] 19:16:40 INFO - 10 libxul.so!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [MessagePump.cpp:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 333 + 0x10]
[task 2019-04-17T19:16:40.609Z] 19:16:40 INFO - eip = 0xed5e7320 esp = 0xdeaaa170 ebp = 0xdeaaa1a8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.609Z] 19:16:40 INFO - esi = 0xdbdea560 edi = 0xdeaaa248
[task 2019-04-17T19:16:40.610Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.611Z] 19:16:40 INFO - 11 libxul.so!MessageLoop::RunInternal() [message_loop.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 315 + 0x16]
[task 2019-04-17T19:16:40.611Z] 19:16:40 INFO - eip = 0xed59f4c7 esp = 0xdeaaa1b0 ebp = 0xdeaaa1d8 ebx = 0xf538e000
[task 2019-04-17T19:16:40.612Z] 19:16:40 INFO - esi = 0xdeaaa248 edi = 0xdeaaa1e8
[task 2019-04-17T19:16:40.613Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.614Z] 19:16:40 INFO - 12 libxul.so!MessageLoop::Run() [message_loop.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 290 + 0x8]
[task 2019-04-17T19:16:40.615Z] 19:16:40 INFO - eip = 0xed59f424 esp = 0xdeaaa1e0 ebp = 0xdeaaa208 ebx = 0xf538e000
[task 2019-04-17T19:16:40.615Z] 19:16:40 INFO - esi = 0xdeaaa248 edi = 0xdeaaa1e8
[task 2019-04-17T19:16:40.616Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.616Z] 19:16:40 INFO - 13 libxul.so!base::Thread::ThreadMain() [thread.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 192 + 0x8]
[task 2019-04-17T19:16:40.617Z] 19:16:40 INFO - eip = 0xed5a99e1 esp = 0xdeaaa210 ebp = 0xdeaaa358 ebx = 0xf538e000
[task 2019-04-17T19:16:40.618Z] 19:16:40 INFO - esi = 0xdba4a860 edi = 0xdeaaa248
[task 2019-04-17T19:16:40.618Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.619Z] 19:16:40 INFO - 14 libxul.so!ThreadFunc(void*) [platform_thread_posix.cc:30271e4881e7a27c75e5490f99908d2e764e8fa4 : 40 + 0x8]
[task 2019-04-17T19:16:40.619Z] 19:16:40 INFO - eip = 0xed5a51c3 esp = 0xdeaaa360 ebp = 0xdeaaa368 ebx = 0xf538e000
[task 2019-04-17T19:16:40.620Z] 19:16:40 INFO - esi = 0x00000000 edi = 0x003d0f00
[task 2019-04-17T19:16:40.621Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.621Z] 19:16:40 INFO - 15 libpthread-2.23.so + 0x6295
[task 2019-04-17T19:16:40.622Z] 19:16:40 INFO - eip = 0xf76dd295 esp = 0xdeaaa370 ebp = 0xdeaaa428 ebx = 0x00000000
[task 2019-04-17T19:16:40.622Z] 19:16:40 INFO - esi = 0x00000000 edi = 0x003d0f00
[task 2019-04-17T19:16:40.623Z] 19:16:40 INFO - Found by: call frame info
[task 2019-04-17T19:16:40.624Z] 19:16:40 INFO - 16 libc-2.23.so + 0xe70ae
[task 2019-04-17T19:16:40.624Z] 19:16:40 INFO - eip = 0xf74080ae esp = 0xdeaaa430 ebp = 0x00000000
[task 2019-04-17T19:16:40.625Z] 19:16:40 INFO - Found by: previous frame's frame pointer
[task 2019-04-17T19:16:40.625Z] 19:16:40 INFO -

Summary: Intermittent dom/media/tests/mochitest/test_getUserMedia_basicScreenshare.html | application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] → Intermittent dom/media/tests/mochitest/| wpt <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()]
Duplicate of this bug: 1545463
Duplicate of this bug: 1545718
Summary: Intermittent dom/media/tests/mochitest/| wpt <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] → Intermittent dom/media/tests/mochitest/| wpt&mda <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] after application terminated with exit code 11
Duplicate of this bug: 1545971

Don't mark intermittent crashes as P5s. We want them to go to triage owners.

Priority: P5 → --
Duplicate of this bug: 1546529
Duplicate of this bug: 1546206

I don't know why this doesn't show up in the triage tool, it seems intended that it should with the priority unset. P2 because it's a crash, but that has no occurrences in the wild.

Priority: -- → P2

In the last 7 days, there have been 46 failures.

Most of the failures are on linux32 and linux32-shippable platform, affected build types: debug, opt.

An example of a recent log file:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=244467365&repo=autoland&lineNumber=28350

And the relevant part of the log:
[task 2019-05-03T12:42:28.309Z] 12:42:28 INFO - TEST-START | /screen-capture/getdisplaymedia.https.html
[task 2019-05-03T12:42:28.316Z] 12:42:28 INFO - Closing window 35
[task 2019-05-03T12:42:28.360Z] 12:42:28 INFO - PID 11804 | [11804, Main Thread] WARNING: '!mSelection', file /builds/worker/workspace/build/src/editor/libeditor/EditorBase.cpp, line 4911
[task 2019-05-03T12:42:28.360Z] 12:42:28 INFO - PID 11804 | [11804, Main Thread] WARNING: '!editActionData.CanHandle()', file /builds/worker/workspace/build/src/editor/libeditor/EditorBase.cpp, line 1314
[task 2019-05-03T12:42:28.404Z] 12:42:28 INFO - PID 11804 | [11804, Main Thread] WARNING: nsIEditActionListener installed, this editor becomes slower: 'mActionListeners.Length() != 1', file /builds/worker/workspace/build/src/editor/libeditor/EditorBase.cpp, line 2155
[task 2019-05-03T12:42:28.448Z] 12:42:28 INFO - PID 11804 | ++DOCSHELL 0xdad0c000 == 18 [pid = 11804] [id = {e216b229-258a-415f-bf26-e924702f0714}]
[task 2019-05-03T12:42:28.448Z] 12:42:28 INFO - PID 11804 | ++DOMWINDOW == 48 (0xe4754570) [pid = 11804] [serial = 48] [outer = (nil)]
[task 2019-05-03T12:42:28.456Z] 12:42:28 INFO - PID 11804 | ++DOMWINDOW == 49 (0xdb27cc00) [pid = 11804] [serial = 49] [outer = 0xe4754570]
[task 2019-05-03T12:42:28.517Z] 12:42:28 INFO - PID 11804 | ++DOMWINDOW == 50 (0xdd344800) [pid = 11804] [serial = 50] [outer = 0xe4754570]
[task 2019-05-03T12:42:28.997Z] 12:42:28 INFO - PID 11804 | ++DOCSHELL 0xdd344c00 == 19 [pid = 11804] [id = {eb9c9111-fc2e-4f92-a325-7b4240fd1c59}]
[task 2019-05-03T12:42:28.998Z] 12:42:28 INFO - PID 11804 | ++DOMWINDOW == 51 (0xdb395450) [pid = 11804] [serial = 51] [outer = (nil)]
[task 2019-05-03T12:42:28.999Z] 12:42:28 INFO - PID 11804 | ++DOMWINDOW == 52 (0xe030e400) [pid = 11804] [serial = 52] [outer = 0xdb395450]
[task 2019-05-03T12:42:29.047Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
[task 2019-05-03T12:42:29.103Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file /builds/worker/workspace/build/src/layout/base/nsDocumentViewer.cpp, line 3127
[task 2019-05-03T12:42:29.186Z] 12:42:29 INFO - PID 11804 | ++DOCSHELL 0xe0af1800 == 20 [pid = 11804] [id = {c9e7f25b-9040-4e3c-a8ed-318beebbd27c}]
[task 2019-05-03T12:42:29.187Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 53 (0xdb395780) [pid = 11804] [serial = 53] [outer = (nil)]
[task 2019-05-03T12:42:29.187Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 54 (0xe0af8400) [pid = 11804] [serial = 54] [outer = 0xdb395780]
[task 2019-05-03T12:42:29.248Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
[task 2019-05-03T12:42:29.305Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file /builds/worker/workspace/build/src/layout/base/nsDocumentViewer.cpp, line 3127
[task 2019-05-03T12:42:29.401Z] 12:42:29 INFO - PID 11804 | --DOCSHELL 0xe22e2400 == 19 [pid = 11804] [id = {83fc651d-3d9c-4323-ba59-c42c214fd36b}] [url = moz-extension://fb7a70ab-39b7-4f0a-b2a4-bde3e988d818/_generated_background_page.html]
[task 2019-05-03T12:42:29.422Z] 12:42:29 INFO - PID 11804 | ++DOCSHELL 0xdb284800 == 20 [pid = 11804] [id = {ba9b1134-af10-47a9-b570-ef03a8423a97}]
[task 2019-05-03T12:42:29.423Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 55 (0xdb395ab0) [pid = 11804] [serial = 55] [outer = (nil)]
[task 2019-05-03T12:42:29.423Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 56 (0xdc8c4c00) [pid = 11804] [serial = 56] [outer = 0xdb395ab0]
[task 2019-05-03T12:42:29.464Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
[task 2019-05-03T12:42:29.512Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file /builds/worker/workspace/build/src/layout/base/nsDocumentViewer.cpp, line 3127
[task 2019-05-03T12:42:29.600Z] 12:42:29 INFO - PID 11804 | ++DOCSHELL 0xdd344400 == 21 [pid = 11804] [id = {31006d3b-a630-487d-82e4-7475a11faa25}]
[task 2019-05-03T12:42:29.601Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 57 (0xdb395bc0) [pid = 11804] [serial = 57] [outer = (nil)]
[task 2019-05-03T12:42:29.602Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 58 (0xe030ac00) [pid = 11804] [serial = 58] [outer = 0xdb395bc0]
[task 2019-05-03T12:42:29.644Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
[task 2019-05-03T12:42:29.700Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file /builds/worker/workspace/build/src/layout/base/nsDocumentViewer.cpp, line 3127
[task 2019-05-03T12:42:29.782Z] 12:42:29 INFO - PID 11804 | ++DOCSHELL 0xe0afc000 == 22 [pid = 11804] [id = {8b6f1c21-abb8-4ae5-bc9e-54f1702d2187}]
[task 2019-05-03T12:42:29.782Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 59 (0xdb395cd0) [pid = 11804] [serial = 59] [outer = (nil)]
[task 2019-05-03T12:42:29.784Z] 12:42:29 INFO - PID 11804 | ++DOMWINDOW == 60 (0xe0afd000) [pid = 11804] [serial = 60] [outer = 0xdb395cd0]
[task 2019-05-03T12:42:29.824Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x805D0021: file /builds/worker/workspace/build/src/modules/libjar/nsJARChannel.cpp, line 994
[task 2019-05-03T12:42:29.873Z] 12:42:29 INFO - PID 11804 | [11804, Main Thread] WARNING: NS_ENSURE_TRUE(root) failed: file /builds/worker/workspace/build/src/layout/base/nsDocumentViewer.cpp, line 3127
[task 2019-05-03T12:42:29.969Z] 12:42:29 INFO - PID 11804 | ExceptionHandler::GenerateDump cloned child 11924
[task 2019-05-03T12:42:29.970Z] 12:42:29 INFO - PID 11804 | ExceptionHandler::SendContinueSignalToChild sent continue signal to child
[task 2019-05-03T12:42:29.970Z] 12:42:29 INFO - PID 11804 | ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[task 2019-05-03T12:42:30.187Z] 12:42:30 INFO - IOError on command, setting status to CRASH
[task 2019-05-03T12:42:30.191Z] 12:42:30 INFO - mozcrash Copy/paste: /builds/worker/workspace/build/linux64-minidump_stackwalk /tmp/tmpVyhzzw.mozrunner/minidumps/421c9d14-58bd-1967-64a5-0028e95d886a.dmp /builds/worker/workspace/build/symbols
[task 2019-05-03T12:42:37.416Z] 12:42:37 INFO - mozcrash Saved minidump as /builds/worker/workspace/build/blobber_upload_dir/421c9d14-58bd-1967-64a5-0028e95d886a.dmp
[task 2019-05-03T12:42:37.416Z] 12:42:37 INFO - mozcrash Saved app info as /builds/worker/workspace/build/blobber_upload_dir/421c9d14-58bd-1967-64a5-0028e95d886a.extra
[task 2019-05-03T12:42:37.624Z] 12:42:37 INFO - PROCESS-CRASH | /screen-capture/getdisplaymedia.https.html | application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()]
[task 2019-05-03T12:42:37.625Z] 12:42:37 INFO - Crash dump filename: /tmp/tmpVyhzzw.mozrunner/minidumps/421c9d14-58bd-1967-64a5-0028e95d886a.dmp
[task 2019-05-03T12:42:37.625Z] 12:42:37 INFO - Operating system: Linux
[task 2019-05-03T12:42:37.626Z] 12:42:37 INFO - 0.0.0 Linux 4.4.0-1014-aws #14taskcluster1-Ubuntu SMP Tue Apr 3 10:27:00 UTC 2018 x86_64
[task 2019-05-03T12:42:37.626Z] 12:42:37 INFO - CPU: x86
[task 2019-05-03T12:42:37.627Z] 12:42:37 INFO - GenuineIntel family 6 model 62 stepping 4
[task 2019-05-03T12:42:37.627Z] 12:42:37 INFO - 4 CPUs
[task 2019-05-03T12:42:37.627Z] 12:42:37 INFO -
[task 2019-05-03T12:42:37.627Z] 12:42:37 INFO - GPU: UNKNOWN
[task 2019-05-03T12:42:37.628Z] 12:42:37 INFO -
[task 2019-05-03T12:42:37.628Z] 12:42:37 INFO - Crash reason: SIGSEGV /SEGV_ACCERR
[task 2019-05-03T12:42:37.628Z] 12:42:37 INFO - Crash address: 0xdb8ff004
[task 2019-05-03T12:42:37.629Z] 12:42:37 INFO - Process uptime: not available
[task 2019-05-03T12:42:37.629Z] 12:42:37 INFO -
[task 2019-05-03T12:42:37.630Z] 12:42:37 INFO - Thread 58 (crashed)
[task 2019-05-03T12:42:37.630Z] 12:42:37 INFO - 0 libxul.so!webrtc::MouseCursorMonitorX11::CaptureCursor() [mouse_cursor_monitor_x11.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 218 + 0x0]
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - eip = 0xf07c5fa3 esp = 0xe4e788f0 ebp = 0xe4e789d8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - esi = 0xdb8fe000 edi = 0xe4e4e4e4 eax = 0xdb2017f4 ecx = 0xdb201900
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - edx = 0xdb8ff004 efl = 0x00010283
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - Found by: given as instruction pointer in context
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - 1 libxul.so!webrtc::MouseCursorMonitorX11::Init(webrtc::MouseCursorMonitor::Callback*, webrtc::MouseCursorMonitor::Mode) [mouse_cursor_monitor_x11.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 124 + 0x9]
[task 2019-05-03T12:42:37.631Z] 12:42:37 INFO - eip = 0xf07c5de6 esp = 0xe4e789e0 ebp = 0xe4e78ac8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - esi = 0xdadb48e0 edi = 0xe4e789f8
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - 2 libxul.so!webrtc::DesktopAndCursorComposer::Start(webrtc::DesktopCapturer::Callback*) [desktop_and_cursor_composer.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 158 + 0xf]
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - eip = 0xf07c3b94 esp = 0xe4e78ad0 ebp = 0xe4e78ae8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - esi = 0xdb34a250 edi = 0xdc0dec00
[task 2019-05-03T12:42:37.632Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.633Z] 12:42:37 INFO - 3 libxul.so!webrtc::DesktopCaptureImpl::StartCapture(webrtc::VideoCaptureCapability const&) [desktop_capture_impl.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 593 + 0x12]
[task 2019-05-03T12:42:37.633Z] 12:42:37 INFO - eip = 0xef4101fe esp = 0xe4e78af0 ebp = 0xe4e78b18 ebx = 0xf5432000
[task 2019-05-03T12:42:37.633Z] 12:42:37 INFO - esi = 0xdad35eb0 edi = 0xdc0dec00
[task 2019-05-03T12:42:37.633Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.633Z] 12:42:37 INFO - 4 libxul.so!non-virtual thunk to webrtc::DesktopCaptureImpl::StartCapture(webrtc::VideoCaptureCapability const&) [desktop_capture_impl.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 0 + 0x23]
[task 2019-05-03T12:42:37.634Z] 12:42:37 INFO - eip = 0xef410265 esp = 0xe4e78b20 ebp = 0xe4e78b38 ebx = 0xf5432000
[task 2019-05-03T12:42:37.634Z] 12:42:37 INFO - esi = 0xdc0dec04 edi = 0xdc0dec04
[task 2019-05-03T12:42:37.634Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.634Z] 12:42:37 INFO - 5 libxul.so!std::_Function_handler<void (mozilla::camera::VideoEngine::CaptureEntry&), mozilla::camera::CamerasParent::RecvStartCapture(mozilla::camera::CaptureEngine const&, int const&, mozilla::camera::VideoCaptureCapability const&)::$_10::operator()() const::{lambda(mozilla::camera::VideoEngine::CaptureEntry&)#1}>::_M_invoke(std::_Any_data const&, mozilla::camera::VideoEngine::CaptureEntry&) [functional:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 1731 + 0x46c]
[task 2019-05-03T12:42:37.635Z] 12:42:37 INFO - eip = 0xef415d11 esp = 0xe4e78b40 ebp = 0xe4e78bb8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.635Z] 12:42:37 INFO - esi = 0xdc0dec04 edi = 0xdc0dec04
[task 2019-05-03T12:42:37.635Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.635Z] 12:42:37 INFO - 6 libxul.so!mozilla::camera::VideoEngine::WithEntry(int, std::function<void (mozilla::camera::VideoEngine::CaptureEntry&)> const&&) [VideoEngine.cpp:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 251 + 0x13]
[task 2019-05-03T12:42:37.635Z] 12:42:37 INFO - eip = 0xef40b264 esp = 0xe4e78bc0 ebp = 0xe4e78be8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.636Z] 12:42:37 INFO - esi = 0xdad2034c edi = 0xdbf5a904
[task 2019-05-03T12:42:37.636Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.636Z] 12:42:37 INFO - 7 libxul.so!mozilla::media::LambdaRunnable<mozilla::camera::CamerasParent::RecvStartCapture(mozilla::camera::CaptureEngine const&, int const&, mozilla::camera::VideoCaptureCapability const&)::$_10>::Run() [MediaUtils.h:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 73 + 0x158]
[task 2019-05-03T12:42:37.636Z] 12:42:37 INFO - eip = 0xef4156d6 esp = 0xe4e78bf0 ebp = 0xe4e78c48 ebx = 0xf5432000
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - esi = 0xe4e78c20 edi = 0xdad4cb80
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - 8 libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 1180 + 0x16]
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - eip = 0xecf9e8f9 esp = 0xe4e78c50 ebp = 0xe4e79138 ebx = 0xf5432000
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - esi = 0xe4e78cc0 edi = 0xdc12c280
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - 9 libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 486 + 0x11]
[task 2019-05-03T12:42:37.637Z] 12:42:37 INFO - eip = 0xecfa11f6 esp = 0xe4e79140 ebp = 0xe4e79168 ebx = 0xf5432000
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - esi = 0xe4e7915b edi = 0xe4e79248
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - 10 libxul.so!mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [MessagePump.cpp:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 333 + 0x10]
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - eip = 0xed51e980 esp = 0xe4e79170 ebp = 0xe4e791a8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - esi = 0xdb887110 edi = 0xe4e79248
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.638Z] 12:42:37 INFO - 11 libxul.so!MessageLoop::RunInternal() [message_loop.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 315 + 0x16]
[task 2019-05-03T12:42:37.639Z] 12:42:37 INFO - eip = 0xed4d6683 esp = 0xe4e791b0 ebp = 0xe4e791d8 ebx = 0xf5432000
[task 2019-05-03T12:42:37.639Z] 12:42:37 INFO - esi = 0xe4e79248 edi = 0xe4e791e8
[task 2019-05-03T12:42:37.639Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.639Z] 12:42:37 INFO - 12 libxul.so!MessageLoop::Run() [message_loop.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 290 + 0x8]
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - eip = 0xed4d65e0 esp = 0xe4e791e0 ebp = 0xe4e79208 ebx = 0xf5432000
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - esi = 0xe4e79248 edi = 0xe4e791e8
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - 13 libxul.so!base::Thread::ThreadMain() [thread.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 192 + 0x8]
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - eip = 0xed4e0b9d esp = 0xe4e79210 ebp = 0xe4e79358 ebx = 0xf5432000
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - esi = 0xdad21f40 edi = 0xe4e79248
[task 2019-05-03T12:42:37.640Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - 14 libxul.so!ThreadFunc(void*) [platform_thread_posix.cc:39af0d6ccd3d911cae7d0ddadb0b0baae979046d : 40 + 0x8]
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - eip = 0xed4dc37f esp = 0xe4e79360 ebp = 0xe4e79368 ebx = 0xf5432000
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - esi = 0x00000000 edi = 0x003d0f00
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - 15 libpthread-2.23.so + 0x6295
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - eip = 0xf7788295 esp = 0xe4e79370 ebp = 0xe4e79428 ebx = 0x00000000
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - esi = 0x00000000 edi = 0x003d0f00
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - Found by: call frame info
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - 16 libc-2.23.so + 0xe70ae
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - eip = 0xf74b30ae esp = 0xe4e79430 ebp = 0x00000000
[task 2019-05-03T12:42:37.641Z] 12:42:37 INFO - Found by: previous frame's frame pointer

:drno As you are the triage owner of this component, could you please take a look at this?
Thank you!

Flags: needinfo?(drno)
Whiteboard: [stockwell needswork:owner]
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

Joel can you please take a look at this?

There are 69 total failures in the last 7 days on linux32 debug and linux32-shippable opt.

Flags: needinfo?(jmaher)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

we will be adjusting the tests we run on linux32 starting next week. wpt will be run on shippable and not debug, so in this case the wpt failures will magically go away. mda jobs here are failing on shippable and the plan is to run only wpt on linux32/shippable, so this failure will not be seen.

Flags: needinfo?(jmaher)
Flags: needinfo?(drno)
Whiteboard: [stockwell needswork:owner] → [stockwell needswork:owner][comment 17]
Whiteboard: [stockwell needswork:owner][comment 17] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Duplicate of this bug: 1550943
Summary: Intermittent dom/media/tests/mochitest/| wpt&mda <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] after application terminated with exit code 11 → Intermittent dom/media/tests/mochitest/| <test-name>| application crashed [@ webrtc::MouseCursorMonitorX11::CaptureCursor()] after application terminated with exit code 11

Looks like the crash is happening on a line changed by the Pipewire support import in Bug 1496359.

Regressed by: 1496359
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]

There are 139 total failures in the last 7 days on linux32 debug and linux32-shippable opt.

Joel did the adjustment process mentioned in comment 17 start? the failure rate did not go down, it increased in the past week compared to two weeks ago.

Flags: needinfo?(jmaher)
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]

oh, that was delayed a week (as we slipped our merge schedule a week)- we are on schedule for that to happen on Tuesday in bug 1548649

Flags: needinfo?(jmaher)
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Depends on: 1548649
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]
Whiteboard: [comment 17][stockwell disable-recommended] → [comment 17]

In the last 7 days there have been 50 occurrences on Linux 32 Opt and Debug.

The crash is due to the cast here [1]. The XFixesCursorImage defines pixels as long, which is not a uint64_t on 32 bit linux. When I checked, upstream has already fixed this here [2].

[1] https://searchfox.org/mozilla-central/source/media/webrtc/trunk/webrtc/modules/desktop_capture/linux/mouse_cursor_monitor_x11.cc#214
[2] https://webrtc-review.googlesource.com/c/src/+/134541

Assignee: nobody → dminor
Status: NEW → ASSIGNED
Whiteboard: [comment 17][stockwell disable-recommended]

This is a cherry pick of upstream commit c1187ab34bdf836bd33f7f050d525184eba4cd20.

Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ba49ec6ff971
Fix crash in MouseCursorMonitorX11::CaptureCursor() on linux32; r=ng
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(dminor)

Comment on attachment 9068019 [details]
Bug 1545247 - Fix crash in MouseCursorMonitorX11::CaptureCursor() on linux32; r=ng!

Beta/Release Uplift Approval Request

  • User impact if declined: Crashes on 32 bit linux platforms when doing desktop capture.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is low risk because it is a cherry pick of a revision that has already landed on upstream webrtc.org at the beginning of April.
  • String changes made/needed: None
Flags: needinfo?(dminor)
Attachment #9068019 - Flags: approval-mozilla-beta?

Comment on attachment 9068019 [details]
Bug 1545247 - Fix crash in MouseCursorMonitorX11::CaptureCursor() on linux32; r=ng!

I love this bit of xlib's API. Approved for 68.0b7.

Attachment #9068019 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.