Closed Bug 154536 Opened 18 years ago Closed 17 years ago

DNS: stops resolving for long period of time

Categories

(Core :: Networking, defect)

x86
FreeBSD
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 135724

People

(Reporter: ugly, Unassigned)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; FreeBSD i386; U;) Gecko/0
BuildID:    0000000000

Sometimes immediately at the start of mozilla, or sometime later, hostnames stop
resolving properly.  After a minute or so the hostname eventually resolves and
the page loads.  This happens regardless of the hostname.  During the time it
stops resolving, I am able to resolve hosts with other applications including
the 'host' application.  I run a caching nameserver which is functioning fine,
the problem is only with mozilla.  I have HTTP pipelining disabled.  This
happens every single time the browser is open (eventually).  During the time
mozilla is not resolving hosts, if I substitute in the IP for the hostname the
page WILL load, but only with an IP at that time.  NOTE: I'm using galeon,
however this happens in mozilla without galeon as well.

Reproducible: Always
Steps to Reproduce:
1. going to websites seems to be enough

uname -a output: FreeBSD whorism 4.6-STABLE FreeBSD 4.6-STABLE #0: Wed Jun 26
23:08:00 EDT 2002     ugly@whorism:/usr/obj/usr/src/sys/WHORISM  i386
any opinons on this being OS specific?
Whiteboard: checkMac, checkWin
Summary: DNS stops resolving for long period of time in mozilla only → DNS: stops resolving for long period of time
does this problem still exist in 1.1beta?
I have not tried 1.1beta yet as I use the FreeBSD port..
If you stop resolving, do the already-resolved addresses (in DNS cache) still work?
Benjamin: no, they don't
What is the most recent milestone you can run?
Benjamin: I was able to run 1.1.  I haven't tried 1.2 alpha.  I recently
switched from FreeBSD back to Linux for a non-mozilla issue, so I might not be
able to answer all future questions, but I will try.

-Andrew
I also have this problem.  I had it with mozilla 1.0rc3 on FreeBSD 4.6.2 and
still have it with mozilla 1.1 on FreeBSD 4.7.  My work around is to quit then
restart mozilla.

Bug 146769 is the same as this bug.
Actually this sounds more like bug 135724, because of its FreeBSD nature. 
Marking duplicate.

*** This bug has been marked as a duplicate of 135724 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified duplicate
Status: RESOLVED → VERIFIED
QA Contact: benc → tever
V/d - this apears to be bsd-only
Whiteboard: checkMac, checkWin
You need to log in before you can comment on or make changes to this bug.