Closed Bug 1545375 Opened 4 months ago Closed 4 months ago

calendar tasks broken

Categories

(Calendar :: Tasks, defect)

Lightning 7.0
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mkmelin, Assigned: pmorris)

References

(Regression)

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1531096 +++

The task tree seems broken on trunk for some reason (from bug 1531096). I get these, the middle one perhaps not related:

TypeError: this.mTreeView is null calendar-task-tree.js:294:21
connectedCallback chrome://calendar/content/calendar-task-tree.js:294
forEach self-hosted:266
connectedCallback chrome://calendar/content/calendar-task-tree.js:280
<anonymous> chrome://calendar/content/calendar-task-tree.js:624
loadScript resource:///modules/Overlays.jsm:477
load resource:///modules/Overlays.jsm:195
load resource:///modules/Overlays.jsm:40
register chrome://messenger/content/parent/ext-legacy.js:131
forEach self-hosted:266
register chrome://messenger/content/parent/ext-legacy.js:131
InterpretGeneratorResume self-hosted:1284
AsyncFunctionNext self-hosted:839

TypeError: this._updateScrollButtonsDisabledState is not a function scrollbox.xml:51:14
arrowscrollbox_XBL_Constructor chrome://global/content/bindings/scrollbox.xml:51
connectedCallback chrome://global/content/elements/menupopup.js:50
connectedCallback chrome://calendar/content/calendar-menus.js:73
<anonymous> chrome://calendar/content/calendar-menus.js:116
loadScript resource:///modules/Overlays.jsm:477
load resource:///modules/Overlays.jsm:195
load resource:///modules/Overlays.jsm:40
register chrome://messenger/content/parent/ext-legacy.js:131
forEach self-hosted:266
register chrome://messenger/content/parent/ext-legacy.js:131
InterpretGeneratorResume self-hosted:1284
AsyncFunctionNext self-hosted:839

TypeError: this.mFilter is null calendar-task-tree.js:531:28
doUpdateFilter chrome://calendar/content/calendar-task-tree.js:531
updateFilter chrome://calendar/content/calendar-task-tree.js:567
taskViewUpdate chrome://calendar/content/calendar-task-view.js:341
taskViewObserveDisplayDeckChange chrome://calendar/content/calendar-task-view.js:381
set selectedIndex chrome://global/content/elements/general.js:16
set selectedPanel chrome://global/content/elements/general.js:28
ltnSwitch2Task chrome://lightning/content/messenger-overlay-sidebar.js:653
openTab chrome://lightning/content/messenger-overlay-sidebar.js:118
openTab chrome://messenger/content/tabmail.xml:612
restoreTab chrome://lightning/content/messenger-overlay-sidebar.js:144
restoreTab chrome://messenger/content/tabmail.xml:1089
registerTabType chrome://messenger/content/tabmail.xml:366

I wasn't able to reproduce the error. (Possibly because I haven't been able to get column state, like sorted state, to persist across restarts in development context. Maybe that works on daily? That's another story, see bug 1545199.)

But from that first error message I think I see the problem. Just set up the tree view before trying to use it. Fixed with this patch. (Also, when trying to reproduce, I noticed the sort properties are camel cased now instead of kebab case, so I changed that too.)

I think the first error message would cause the 3rd. So this patch may fix that as well.

Assignee: nobody → paul
Attachment #9059275 - Flags: review?(mkmelin+mozilla)
Version: unspecified → Lightning 7.0
Comment on attachment 9059275 [details] [diff] [review]
mTreeView-null-error-0.patch

Review of attachment 9059275 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, this seems to have fixed the issue!
Attachment #9059275 - Flags: review?(mkmelin+mozilla) → review+
Status: NEW → ASSIGNED
Keywords: checkin-needed

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/6065b5e322e8
Fix calendar task tree (this.mTreeView is null error). r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 7.0
You need to log in before you can comment on or make changes to this bug.