Closed Bug 1545806 Opened 7 months ago Closed 7 months ago

DualShock 4 has problem to access axes when in Release

Categories

(Core :: DOM: Device Interfaces, defect)

68 Branch
Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: daoshengmu, Assigned: daoshengmu)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

It is good in Debug build and only happens in Release build. I guess we might have some variables didn't be initialized correctly.

Assignee: nobody → dmu
Blocks: 1523350
Type: enhancement → defect

We need to do value(0.0f), active(false) at its initializer list.

Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/127af2f6e16d
Correct the initializer list in Windows gamepad axis value constructor. r=qdot
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 1544297
You need to log in before you can comment on or make changes to this bug.