Get webrtc https proxy for TURN/TCP working with the socket process

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
normal
RESOLVED FIXED
3 months ago
27 days ago

People

(Reporter: bwc, Assigned: bwc)

Tracking

(Blocks 1 bug)

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Fission Milestone:M2, firefox68 fixed)

Details

Attachments

(3 attachments)

No description provided.
Attachment #9059565 - Attachment description: Bug 1545827: (WIP) Use TabId instead of PBrowserOrId, and avoid using the system principal on the socket process. → Bug 1545827: Use TabId instead of PBrowserOrId, use LoadInfoArgs to avoid using the system principal on the socket process, and use PSocketProcess for the WebrtcProxyChannel when on the socket process. r?kershaw r?mjf
Attachment #9059565 - Attachment description: Bug 1545827: Use TabId instead of PBrowserOrId, use LoadInfoArgs to avoid using the system principal on the socket process, and use PSocketProcess for the WebrtcProxyChannel when on the socket process. r?kershaw r?mjf → Bug 1545827: Use TabId instead of PBrowserOrId, use LoadInfoArgs to avoid using the system principal on the socket process, and use PSocketProcess for the WebrtcProxyChannel when on the socket process. r?kershaw,mjf

Depends on D28665

Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7ed63d730876
Use TabId instead of PBrowserOrId, use LoadInfoArgs to avoid using the system principal on the socket process, and use PSocketProcess for the WebrtcProxyChannel when on the socket process. r=kershaw,mjf
https://hg.mozilla.org/integration/autoland/rev/43f6ce8cb91b
Use NrSocketProxy on the socket process, when appropriate. r=mjf
https://hg.mozilla.org/integration/autoland/rev/93e934e867c5
Rename a macro to avoid conflicts. r=mjf,drno
Fission Milestone: --- → M2
Duplicate of this bug: 1509471
You need to log in before you can comment on or make changes to this bug.