Closed Bug 1545859 Opened 6 months ago Closed 6 months ago

set gfx.font_ahem_antialias_none=true for all reftests

Categories

(Core :: Layout: Text and Fonts, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: jmaher, Assigned: jmaher)

References

Details

Attachments

(1 file)

it appears that by doing this we have some visible changes in windows and osx reftests. Most of these are passing conditions which is great.

There is one issue on windows 7 debug where I see a crash:
https://treeherder.mozilla.org/#/jobs?repo=try&searchStr=win%2Creftest&revision=5871ae98f70b92f1761e12af59acd2c478ebf970

it looks to start with an assertion:

the assertion is here:
20:21:56 INFO - Assertion failure: false (d3dcompiler DLL loading failed.), at z:/build/build/src/gfx/gl/GLLibraryEGL.cpp:431
20:22:27 INFO - #01: mozilla::gl::GLLibraryEGL::EnsureInitialized(bool,nsTSubstring<char> * const) [gfx/gl/GLLibraryEGL.cpp:385]
20:22:27 INFO -
20:22:27 INFO - #02: mozilla::gl::GLContextProviderEGL::CreateOffscreen(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gl::SurfaceCaps const &,mozilla::gl::CreateContextFlags,nsTSubstring<char> * const) [gfx/gl/GLContextProviderEGL.cpp:1130]
20:22:27 INFO -
20:22:27 INFO - #03: mozilla::WebGLContext::CreateAndInitGL(bool,std::vector<mozilla::WebGLContext::FailureReason,std::allocator<mozilla::WebGLContext::FailureReason> > * const) [dom/canvas/WebGLContext.cpp:590]
20:22:27 INFO -
20:22:27 INFO - #04: mozilla::WebGLContext::SetDimensions(int,int) [dom/canvas/WebGLContext.cpp:843]
20:22:27 INFO -

and then ends up with a crash:
20:22:51 INFO - Thread 0 (crashed)
20:22:51 INFO - 0 xul.dll!mozilla::gl::GLLibraryEGL::DoEnsureInitialized(bool,nsTSubstring<char> * const) [GLLibraryEGL.cpp:0160424142d14988f7b30595e03f156c31278a42 : 431 + 0x0]
20:22:51 INFO - eip = 0x524e5977 esp = 0x0032d368 ebp = 0x0032d7c4 ebx = 0x00000000
20:22:51 INFO - esi = 0x00e97890 edi = 0x0032d484 eax = 0x739be6b0 ecx = 0x000001af
20:22:51 INFO - edx = 0x00000049 efl = 0x00000202
20:22:51 INFO - Found by: given as instruction pointer in context
20:22:51 INFO - 1 xul.dll!mozilla::gl::GLLibraryEGL::EnsureInitialized(bool,nsTSubstring<char> * const) [GLLibraryEGL.cpp:0160424142d14988f7b30595e03f156c31278a42 : 385 + 0x11]
20:22:51 INFO - eip = 0x524dc746 esp = 0x0032d7cc ebp = 0x0032d7d8 ebx = 0x0c530173
20:22:51 INFO - esi = 0x00e97890 edi = 0x0c53a800
20:22:51 INFO - Found by: call frame info
20:22:51 INFO - 2 xul.dll!mozilla::gl::GLContextProviderEGL::CreateOffscreen(mozilla::gfx::IntSizeTyped<mozilla::gfx::UnknownUnits> const &,mozilla::gl::SurfaceCaps const &,mozilla::gl::CreateContextFlags,nsTSubstring<char> * const) [GLContextProviderEGL.cpp:0160424142d14988f7b30595e03f156c31278a42 : 1130 + 0xc]
20:22:51 INFO - eip = 0x524e0bfb esp = 0x0032d7e0 ebp = 0x0032d824 esi = 0x0032d858
20:22:51 INFO - Found by: call frame info
20:22:51 INFO - 3 xul.dll!mozilla::WebGLContext::CreateAndInitGL(bool,std::vector<mozilla::WebGLContext::FailureReason,std::allocator<mozilla::WebGLContext::FailureReason> > * const) [WebGLContext.cpp:0160424142d14988f7b30595e03f156c31278a42 : 590 + 0x4a]
20:22:51 INFO - eip = 0x53b031ba esp = 0x0032d82c ebp = 0x0032d894 ebx = 0x0c530173
20:22:51 INFO - esi = 0x0032d858 edi = 0x0c53a800
20:22:51 INFO - Found by: call frame info

:jfkthame, this seems to be directly related to setting the preference, is this something you should look at or should I bug jgilbert about webgl?

Flags: needinfo?(jfkthame)

Bugbug thinks this bug is a task, but please change it back in case of error.

Type: defect → task

Assertion failure: false (d3dcompiler DLL loading failed.)

Doesn't seem to make any sense to me; I don't see why the gfx.font_ahem_antialias_none should have any effect on this. Maybe jgilbert will have ideas about what might cause this to fail?

Flags: needinfo?(jfkthame) → needinfo?(jgilbert)

Nothing obvious to me. Does the parent cset test green on try?

Flags: needinfo?(jgilbert)

yes, I tried this a few base m-c revisions, even with artifact/no-artifact; I am really confused why this is the case. running without this change tests seem to be working just fine. I can push again with latest bits- maybe when I was testing over the weekend the machines were in a funky state?

ok, both failed and now running with --no-artifact I cannot reproduce this failure:
https://treeherder.mozilla.org/#/jobs?repo=try&author=jmaher%40mozilla.com&fromchange=0cabfec8dc912a164f5f9d6ae91e2ed1b8bcc867&tochange=3932c5a9f04efd571fe45ec49dc1fc0ff635b41c

sorry to randomize both of you on this bug over some sloppy work.

Priority: -- → P3
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c939f7211ad
Set gfx.font_ahem_antialias_none=True for reftests. r=jfkthame
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → jmaher
You need to log in before you can comment on or make changes to this bug.