Closed Bug 15462 Opened 20 years ago Closed 16 years ago

:root element cannot be made display:inline [BG] [INLINE] (stretches, grows)

Categories

(Core :: Layout, defect, P4)

defect

Tracking

()

RESOLVED INVALID
Future

People

(Reporter: ian, Assigned: bzbarsky)

References

()

Details

(Keywords: css1, testcase, Whiteboard: [Hixie-P2][CSS1-5.6.1])

<broke out of bug 15405>

We don't support 'display:inline' on the root element! The following two
documents should look identical, to the pixel:

 http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/background/19.xml
 http://www.bath.ac.uk/%7Epy8ieh/internet/projects/mozilla/background/19-alt.xml

Currently, the first (the real test) looks like a mess. The second (the control)
looks fine, proving that the layout engine is capable of doing it, just that we
have some code blocking it somewhere.

[ccing David; David: if you see something wrong with that test, please do say!]
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → LATER
QA Contact: petersen → chrisd
Status: RESOLVED → VERIFIED
Verified LATER
Keywords: css1
Migrating from {css1} to css1 keyword. The {css1}, {css2}, {css3} and {css-moz}
radars should now be considered deprecated in favour of keywords.
I am *really* sorry about the spam...
Troy is no longer with us.
Status: VERIFIED → REOPENED
Resolution: LATER → ---
Reassigning to buster and moving to Future.
Target Milestone: --- → Future
...and _actually_ reassigning to buster...
Assignee: troy → buster
Status: REOPENED → NEW
As per meeting with ChrisD yesterday, taking QA.
QA Contact: chrisd → py8ieh=bugzilla
Summary: {css1} We don't support display:inline on the root element! → We don't support display:inline on the root element!
OS: Windows 98 → All
Hardware: PC → All
Summary: We don't support display:inline on the root element! → We don't support display:inline on the root element! [INLINE]
Keywords: mozilla1.2
Whiteboard: [Hixie-P4]
Build reassigning Buster's bugs to Marc.
Assignee: buster → attinasi
Whiteboard: [Hixie-P4] → [Hixie-P4][CSS1-5.6.1]
Severity: minor → normal
Summary: We don't support display:inline on the root element! [INLINE] → :root element cannot be made display:inline [BG] [INLINE] (stretches, grows)
Whiteboard: [Hixie-P4][CSS1-5.6.1] → [Hixie-P2][CSS1-5.6.1]
->boris for fun
Assignee: attinasi → bzbarsky
*** Bug 188947 has been marked as a duplicate of this bug. ***
Priority: P3 → P4
No longer allowed by CSS.
Status: NEW → RESOLVED
Closed: 20 years ago16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.