Closed Bug 1546350 Opened 2 years ago Closed 4 months ago

Reimplement history listeners for session history living in the parent process

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1507287
Tracking Status
firefox68 --- affected

People

(Reporter: peterv, Unassigned)

References

(Blocks 1 open bug)

Details

Bug 1438272 didn't implement session history listeners for remote session history living in the parent process.

Type: defect → task
Priority: -- → P3

There are probably still some session history listeners in sessionStore that need to be fixed.

Fission Milestone: --- → M6b
Flags: needinfo?(alchen)
Flags: needinfo?(alchen)

Hi Alphan, does that mean that all session history listeners for session store are fixed to work with session history in the parent? I seem to remember that the one in browser/components/sessionstore/ContentSessionStore.jsm is only used when session history in the parent is not enabled? What about the ones in browser/components/sessionstore/ContentRestore.jsm? If all of these are fixed for session history in the parent already then I think we can just close this bug as a dupe of bug 1507287.

Flags: needinfo?(alchen)

I don't remember there is anything left.
The session history listeners in ContentSessionStore.jsm and ContentRestore.jsm are only used when the pref is off.
We can remove those listeners when we only have the session history in the parent process.

Flags: needinfo?(alchen)

Ok, great. Let's dupe this for now. We can always open a new bug if there's work remaining to be done that we overlooked.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1507287

Clearing Fission Milestone for bugs resolved as duplicates. We don't need to track duplicates.

Fission Milestone: M6b → ---
You need to log in before you can comment on or make changes to this bug.