test_img_mutations.html fails after running additional clipboard tests in the same browser test session

RESOLVED FIXED in Firefox 68

Status

()

defect
P2
normal
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: jmaher, Assigned: edgar)

Tracking

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

test_img_mutations.html fails after moving clipboard tests from the isolated job to blend in with regular tests.

You can see this test fails on all configs:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6ba44c5d9157a02c97ff3618d8e5c4a101fa1694&searchStr=mochitest-e10s&selectedJob=241874067

I found one intermittent (bug 1274701) that already exists, not sure if this is related or not.

we added these tests:
test_clipboard_events.html
test_bug1170911.html
test_bug1012662_noeditor.html
test_bug1012662_editor.html

here is the log from win10/opt:
21:00:38 INFO - TEST-START | dom/tests/mochitest/general/test_img_mutations.html
21:00:38 INFO - TEST-INFO | started process screenshot
21:00:38 INFO - TEST-INFO | screenshot: exit 0
21:00:38 INFO - Buffered messages logged at 21:00:38
21:00:38 INFO - test 1
21:00:38 INFO - TEST-PASS | dom/tests/mochitest/general/test_img_mutations.html | Should have synchronously selected source
21:00:38 INFO - Buffered messages finished
21:00:38 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/general/test_img_mutations.html | Should have synchronously selected source
21:00:38 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:275:18
21:00:38 INFO - test1@dom/tests/mochitest/general/test_img_mutations.html:74:7
21:00:38 INFO - nextTest/<@dom/tests/mochitest/general/test_img_mutations.html:212:26
21:00:38 INFO - setTimeout handlerSimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:43
21:00:38 INFO - nextTest@dom/tests/mochitest/general/test_img_mutations.html:211:9
21:00:38 INFO - setTimeout handler
SimpleTest_setTimeoutShim@SimpleTest/SimpleTest.js:684:43
21:00:38 INFO - @dom/tests/mochitest/general/test_img_mutations.html:231:9
21:00:38 INFO - TEST-PASS | dom/tests/mochitest/general/test_img_mutations.html | Should have dropped currentSrc
21:00:38 INFO - TEST-PASS | dom/tests/mochitest/general/test_img_mutations.html | Should have synchronously selected source
21:00:38 INFO - Waiting for 1 load and 0 error events
21:00:38 INFO - TEST-PASS | dom/tests/mochitest/general/test_img_mutations.html | expected load
21:00:38 INFO - test 2

:hsinyi- could you let me know if you need more information from me regarding this test failure or if there are concerns disabling this test.

Blocks: 1546459
Flags: needinfo?(htsai)

I'll defer to Edgar for making a suggestion. :)

Flags: needinfo?(htsai) → needinfo?(echen)

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #0)

I found one intermittent (bug 1274701) that already exists, not sure if this is related or not.

It doesn't look like related to bug 1274701 to me.

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #1)

if there are concerns disabling this test.

Please do not disable this test. :)

I am applying bug 1546459 to see if I could reproduce the failure locally.

I could also reproduce the failure locally, and it is caused by https://searchfox.org/mozilla-central/source/dom/tests/mochitest/general/test_clipboard_events.html (I didn't see this failure if I disable test_clipboard_events.html), I suspect maybe test_clipboard_events.html sets something for testing (e.g. preference ..) and not change back.

Flags: needinfo?(echen)

It is caused by the test_clipboard_events.html loads the same image source [1] which is also used in test_img_mutations.html.
So while running test_img_mutations.html, it loads image from the cache and cause this unexpected behaviour.

[1] https://searchfox.org/mozilla-central/rev/75294521381b331f821aad3d6b60636844080ee2/dom/tests/mochitest/general/test_clipboard_events.html#13

Assignee: nobody → echen
Priority: -- → P2
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7e1b8a24398
Always use uncached images in test_img_mutations.html; r=jdm
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.