Closed Bug 1546602 Opened 1 year ago Closed 1 year ago

"Turn On Sync..." button cannot be reached using keyboard navigation when FxA is in the Overflow menu

Categories

(Firefox :: Firefox Accounts, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1477673
Tracking Status
firefox67 --- affected
firefox68 --- affected

People

(Reporter: mberlinger, Assigned: Gijs)

References

Details

Attachments

(1 file)

Attached image keyboard navigation.gif

Affected versions

  • Firefox Nightly 68.0a1 (Build ID 20190423221610)
  • Firefox Beta 67.0b13 (Build ID 20190422163745)

Affected Platforms

  • Windows 10x64
  • Ubuntu 18.04x64
  • Windows 7x64
  • mac Os 10.14

Prerequisites

  • Firefox browser is freshly opened or a browser restart has been performed.
  • User is not authenticated with a Firefox Account.
  • FxA icon is pinned to the Overflow Menu.

Steps to reproduce

  1. From the keyboard press [Ctrl+L] to focus the location bar
  2. Press [Tab] key until the first button from the browser toolbar is selected.
  3. Press the [Right Arrow] key until "More Tools..." menu button is selected.
  4. Press [Enter] key.
  5. Press [Up Arrow] or [Down Arrow] keys in order to select "Firefox Account" button.
  6. Press [Enter] key.
  7. Press [Tab] or [Down Arrow] key in order to select "Turn On Sync..." button.

Expected results

  • "Turn On Sync..." button can be selected using [Tab] or [Down Arrow] key.

Actual results

  • "Turn On Sync..." button cannot be selected using keyboard keys.

Regression range

  • This issue is not a regression.

Notes

  • This issue is reproducible only after a fresh start or restart of the browser, when there is no Firefox Account used for sync.

At least on mac, I can't get the submenu to open at all when using the keyboard. If I open it using the mouse, I can activate the button but it has no focus style so it's hard to see when it's focused.

You reported this affects mac, what OS is the screencast from? Can you clarify what behaviour you're seeing on mac?

Flags: needinfo?(maria.berlinger)
See Also: → 1546633

(In reply to :Gijs (he/him) from comment #1)

At least on mac, I can't get the submenu to open at all when using the keyboard.

Same thing on Windows. I filed bug 1546633. Perhaps you're using a build from before that regression, but then I don't understand why comment #0 says "Firefox Nightly 68.0a1 (Build ID 20190423221610)", which is after. Leaving needinfo for this.

FWIW, I expect this is a dupe of bug 1477673, the fix for which is not on 67, which broke navigation to subviews in the overflow panel but fixed navigating to non-toolbarbuttons on 68. But that'd require some confirmation of where/how you're testing on 68 and that you're seeing the same thing as me.

OK, so per conversation on slack, yes this is technically a dupe of bug 1477673, which is fixed in 68 but not 67, but in 68 we hit bug 1546633 instead.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(maria.berlinger)
Resolution: --- → DUPLICATE
Duplicate of bug: 1477673
You need to log in before you can comment on or make changes to this bug.