Closed Bug 1546983 Opened 1 year ago Closed 1 year ago

Tall videos result in glitchy looking Picture-in-Picture player buttons

Categories

(Toolkit :: Video/Audio Controls, defect, P2)

68 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1545763 +++

STR:

  1. Ensure media.videocontrols.picture-in-picture.enabled and media.videocontrols.picture-in-picture.video-toggle.enabled are set to true
  2. Visit https://facebook.com/ and log in with a valid account
  3. Scroll down until you find a video in portrait mode on your home page
  4. The video starts and the toggle button is displayed
  5. Click on the toggle button to open the Picture in Picture window

ER:

The Picture-in-Picture player window controls should match the spec.

AR:

The buttons in the player window look "duplicated" and stretched. See screenshot.

Note:
If you can't find a video you can use this link:
https://www.facebook.com/watch/?v=326853498025559

Priority: P3 → P2

Do you have time to look at this, JSON_Voorhees?

Flags: needinfo?(djustice)
Duplicate of this bug: 1547762
Duplicate of this bug: 1549170
Assignee: nobody → mconley
Attachment #9063353 - Attachment description: Bug 1546983 - Make Picture-in-Picture player control buttons always a square proportional to the window width. r?dthayer → Bug 1546983 - Make Picture-in-Picture player control buttons always a square proportional to the max window dimension. r?dthayer
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7157a9384870
Make Picture-in-Picture player control buttons always a square proportional to the max window dimension. r=dthayer
https://hg.mozilla.org/integration/autoland/rev/8a953fd10269
Make the Picture-in-Picture player window control buttons less sensitive to being in a thin window. r=dthayer
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/eb3846630789
followup: use background-color instead of background so that browser_parsable_css.js doesn't get mad. rs=mconley
Flags: needinfo?(djustice)

Build ID 20190626093633
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

Verified as fixed on the latest Nightly build on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.