In Reply/Forward Euro symbol disapears from the body and window caption

VERIFIED FIXED in M11

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: marina, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

This happens in Plain text and HTML
Steps to reproduce:
-select a message with Euro symbol from Smoke test folder;
-click Reply(Forward);
//note: in HTML mail there is no Display problem, you see Euro displaying
correctly in Subject and body, the only problem is caption of the window, there
it desappeared (maybe because i have Lat-1 OS)
//note: in Plain text after clicking Reply(forward) you have a Display problem,
there is no Euro in the body;
-send it and get message;
//note : the Euro desappeared from Subjet, thread and body
Could you try a trade mark to check if this is a generic non Latin1 problem?
Status: NEW → ASSIGNED
4.6 sends Euro with a special handling (sends window-1252 code point with
ISO-8859-1 charset label). We need to decide how to deal with this case.
Subject: This is EURO =?iso-8859-1?Q?=80?= with 4.6
4.6 also generates trade mark as below.
Subject: testing trade mark =?iso-8859-1?Q?=99?=
Target Milestone: M12
Summary: In Reply/Forward Euro symbol dessapears from the body and window caption → In Reply/Forward Euro symbol disapears from the body and window caption
Depends on: 8865
Add 8865 (entity covnersion) to depends. For html body, it needs the entity
converter with € support. For plain text, we should either send the mail as
UTF-8 (since ISO-8859-1 has no mapping for Euro) or put '?' instead.
Current behavior for unmapped character is to skip that character. That's the
reason of the current problem.
HTML fallback is complete (Euro is sent as €). As a part of the fix,
entities are only generated as fallbacks (e.g. ISO-8859-1 mail generates €
but not Á).
The spec is in
http://www.mozilla.org/projects/intl/mail-news-i18n-spec.html
For plain text, fallback is always '?'. UTF-8 option is not done, we need a pref
(with UI maybe). I would like to do that as a part of  but I would like to do
that as a part of 9574 (Transliteration API). So mark this bug as fixed.
Note that there is a bug in ISO-2022-JP encoder (15706) so the fallback is not
correct but other charset should work fine.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Blocks: 17432
Status: RESOLVED → REOPENED
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Target Milestone: M12 → M11
Status: RESOLVED → REOPENED
I'm reopening this bug based on 1999-11-09-09-M11 win build:
after getting the message euro is displayed as a "?" in the thread pane and
Subject header
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
after discussion with Kat removed the resolutioin "reopned" and left it as fixed
Status: RESOLVED → VERIFIED
** Checked with 11/9/99 Win32 build (1999110911) **

As marina correctly noted, the current solution leaves an
impression of a problem since the original material looks
properly quoted but when it's sent out the EURO is replaced by
the question mark. Also for those used to 4.x behavior, this
feels strange.

We need to look for some ways to correct these user level
impressions and do the right thing. This will be dealt with
in another bug.

For the current bug, the following spec has been established.

For both HTML and Plain text headers:

The EURO and other special symbols which do not exist on
the ISO-8859-1 table will be substituted for with "?".

For HTML body:

These special symbols (e.g. EURO) not on the chosen mail
charset (e.g. ISO-8859-1) will be represented by entities (CERs or NCRs).

For Plain text body:

These special symbols (e.eg. EURO) not on the chosen mail
charset (e.g. ISO-8859-1) will be reprsented by the "question" mark
or possibly something like "EUR" as was done in 4.06/4.5 and later.

The 11/9/99 Win32 build behaves in a manner consistent with the above
spec and thus this bug fix has been verified.

We will deal with these additional issues in another bug.
CC'ed bobj.
Possibly, when we convert to plain text, we want to transliterate characters
that do not exist in the target charset of the conversion.  E.g., in Japanese
plain text mail we might convert a copyright symbol to "(c)" and a Euro symbol
to "EUR".  See bug 9574, Transliteration API.
No longer blocks: 17432
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.