Closed Bug 1547575 Opened 4 months ago Closed Last month

picture in picture video not shown if second screen attached

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1565117

People

(Reporter: aryx, Unassigned)

References

(Blocks 1 open bug)

Details

Firefox Nightly 68.0a1 20190428094048 on Windows 8.1

The setup is a notebook with a 1920x1080 screen. Using that alone, triggering a picture-in-picture display of a video works like this:

  1. Open a youtube video.
  2. Right-click it.
  3. Dismiss the menu and right-click again.
  4. Choose 'Picture in picture'.
    Actual result: small video shown at bottom left.

If a second screen (4K) is attached and placed above the working area of the main screen, the instructions above will open a window for the video which will be shown in the task bar and the task bar preview will show the content playing, but it's shown nowhere on the screens. It doesn't matter if the window for which the PiP is triggered is on the smaller or bigger screen.

Blocks: 1527926
No longer blocks: 1521954
Priority: -- → P3

Hi aryx, bug 1565117 landed recently which should improve multi-monitor support. Are you still able to reproduce this bug on a recent Nightly?

Flags: needinfo?(aryx.bugmail)

The video is shown with Nightly 70.0a1 20190719094503.

It will always open on the big screen (in the bottom right corner), independent from the position of the browser window. Is that intended?

Status: NEW → RESOLVED
Closed: Last month
Flags: needinfo?(aryx.bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1565117

independent from the position of the browser window

No - it's supposed to always open on the same screen as the browser window that spawned it.

You need to log in before you can comment on or make changes to this bug.