Closed Bug 1547619 Opened 6 months ago Closed 6 months ago

:-moz-use-shadow-tree-root pseudo-class code is wrong.

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Regression)

Details

Attachments

(1 file)

The following code:

https://searchfox.org/mozilla-central/rev/66086345467c69685434dd1c5177b30a7511b1a5/servo/components/style/gecko/wrapper.rs#868

Matches even if the <symbol> element is not in the shadow tree.

It should also check self.parent_node().map_or(false, |p| p.is_shadow_root()) or such.

But I think we can get rid of the pseudo-class entirely and all the associated code for symbol frames now we use Shadow DOM for this stuff.

Flags: needinfo?(emilio)
Flags: needinfo?(emilio)
Regressed by: 1450250

Turns out removing the pseudo-class and such ends up not being quite as trivial
as I initially thought, or possible at all, since the fact that the <symbol> is
a <symbol> is observable via selectors, added a test for that.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fcb59a0c2c44
Fix :-moz-svg-use-shadow-tree-root pseudo-class. r=violet
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/16711 for changes under testing/web-platform/tests
You need to log in before you can comment on or make changes to this bug.