If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HR in PRE doesn't resize (Horizontal scrollbar in FTP always visible)

RESOLVED WORKSFORME

Status

()

Core
Layout
P1
normal
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: nomoreregistrations, Assigned: Marc Attinasi)

Tracking

({regression, testcase, top100})

Trunk
Future
x86
All
regression, testcase, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Horizontal scrollbar is always visible on mozilla's own web site,
http://ftp.mozilla.org/pub/mozilla/nightly/latest/ regardless of the window size.

This is a regresion which was not present in Mozilla 1.1 alpha.

Comment 1

15 years ago
WFM Mozilla 1.1 alpha Build ID: 2002062713, Windows 98.

What version of Mozilla are you using?

Please use the Bugzilla Helper to report bugs.
Worksforme in a current Linux trunk build.
The <hr> is too wide... I cannot create a testcase to reproduce this even if I
copy all the source view-source shows shows...
(Reporter)

Comment 4

15 years ago
<html>
<body>

<pre>

<hr>

text<br>
text<br>
text<br>
text<br>
text<br>
text<br>

</pre>

</body>
</html>

Here is the minimum test case.
Adjust the window size so that the vertical scrollbar becomes visible -
horizontal scrollbar will always become visible too. The problem is that when
<hr> is inside <pre></pre> it's size doesn't change with the appearence of the
vertical scrollbar which causes horizontal scrollbar to appear also. When <hr>
is outside of <pre></pre> it works correctly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020629
Created attachment 89976 [details]
simple testcase with HR in PRE
Attachment #89976 - Attachment is patch: false
Attachment #89976 - Attachment mime type: text/plain → text/html
This seems like a pretty highly visible regression.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Summary: Horizontal scrollbar always visible, regardless of the window size → HR in PRE doesn't resize (Horizontal scrollbar in FTP always visible)

Comment 7

15 years ago
regression between linux trunk builds 2002061108 and 2002061304
Keywords: regression
OS: Windows XP → All
Hmm.  Probably a regression from bug 141054.

Updated

15 years ago
Target Milestone: --- → Future

Updated

15 years ago
Keywords: testcase

Comment 9

15 years ago
Still occurs in the OS X 2002-07-31-05 NB.

Comment 10

15 years ago
*** Bug 174627 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
Adding top100 since my bug which was duped here is caused on all Apache
directory index pages.
Keywords: top100
Is this a dupe of Bug 82333?  That was opened before this apparenty regressed
though.
Depends on: 82333

Comment 13

14 years ago
*** Bug 211170 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
Right, I hope I'm don't end up having to extract my foot from my mouth - but
this appears to have been fixed (possibly quite recently). I can't put my finger
on the fix in Bonsai but I've looked at all the testcases under bug 154776, bug
82333 and bug 60922. All the test cases work in recent Camino (2003081002) and
the latest Mozilla 1.5b dev (2003081303). In particular the <hr> elements on ftp
sites / Apache index pages all work.

Marking all 3 of these bugs as WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
It got fixed by the patch in bug 38370 in case anyone cares..
You need to log in before you can comment on or make changes to this bug.