Open Bug 1548125 Opened 4 months ago Updated 3 days ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /media-source/mediasource-correct-frames.html | Test the expected frames are played at the expected times - Test timed out

Categories

(Core :: Audio/Video: Playback, defect, P5)

defect

Tracking

()

People

(Reporter: intermittent-bug-filer, Unassigned, NeedInfo)

References

(Regression)

Details

(Keywords: intermittent-failure, leave-open, regression, Whiteboard: [stockwell disabled])

Attachments

(1 file)

Filed by: dvarga [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=243717362&repo=mozilla-inbound
Full log: https://queue.taskcluster.net/v1/task/dbao1MemRAODxHrmQsiC1w/runs/0/artifacts/public/logs/live_backing.log


19:46:36     INFO - 
19:46:36     INFO - TEST-UNEXPECTED-TIMEOUT | /media-source/mediasource-correct-frames.html | Test the expected frames are played at the expected times - Test timed out
19:46:36     INFO - TEST-UNEXPECTED-ERROR | /media-source/mediasource-correct-frames.html | uncaught exception: Error: assert_equals: Boxes lit at video ended event expected 7 but got 4
19:46:36     INFO - onEnded@http://web-platform.test:8000/media-source/mediasource-correct-frames.html:140:13
19:46:36     INFO - EventListener.handleEvent*@http://web-platform.test:8000/media-source/mediasource-correct-frames.html:83:22
19:46:36     INFO - async*window.mediasource_test/</<@http://web-platform.test:8000/media-source/mediasource-util.js:363:17
19:46:36     INFO - onSourceOpen@http://web-platform.test:8000/media-source/mediasource-util.js:145:13
19:46:36     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1587:25
19:46:36     INFO - Test.prototype.step_func/<@http://web-platform.test:8000/resources/testharness.js:1611:35
19:46:36     INFO - EventListener.handleEvent*openMediaSource_@http://web-platform.test:8000/media-source/mediasource-util.js:148:21
19:46:36     INFO - window.mediasource_test/<@http://web-platform.test:8000/media-source/mediasource-util.js:361:13
19:46:36     INFO - window.media_test/<@http://web-platform.test:8000/media-source/mediasource-util.js:339:13
19:46:36     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1587:25
19:46:36     INFO - async_test@http://web-platform.test:8000/resources/testharness.js:576:22
19:46:36     INFO - window.media_test@http://web-platform.test:8000/media-source/mediasource-util.js:336:16
19:46:36     INFO - window.mediasource_test@http://web-platform.test:8000/media-source/mediasource-util.js:344:16
19:46:36     INFO - @http://web-platform.test:8000/media-source/mediasource-correct-frames.html:70:5
19:46:36     INFO - TEST-INFO took 60278ms
19:46:36     INFO - PID 10180 | 1556653596403	Marionette	INFO	Stopped listening on port 2828
19:46:36     INFO - PID 10180 | [Parent 5948, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 4704, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 4704, Chrome_Chil[Parent 5948, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 6128, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 6128, Chrome_ChildThread] WARNING: pipe er[Child 7712, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 7712,[Parent 5948, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 3988, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 3988, Chrome_ChildThread] W[Parent 5948, Gecko_IOThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 2320, Chrome_ChildThread] WARNING: pipe error: 109: file z:/task_1556643309/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 341
19:46:36     INFO - PID 10180 | [Child 2320, Chrome_[GPU 6156, Chrome_ChildThread
19:46:36     INFO - Browser exited with return code 0
19:46:36     INFO - PROCESS LEAKS None
19:46:36     INFO - Closing logging queue

There are 50 total failures in the last 7 days on windows10-64 opt and debug, windows10-64-shippable opt and windows10-64-qr opt.

James can you take a look? seems to be from Bug 1544415

Flags: needinfo?(james)
Regressed by: 1544415

I think someone from the media team needs to look at this, so redirecting to drno as the triage owner.

Flags: needinfo?(james) → needinfo?(drno)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

This bug is on disabled recommended list. 55 failures are associated with this bug in the last 7 days and 232 in the last 30 days.

Platform breakdown:
windows

:jgraham, should we disable this?

Flags: needinfo?(james)
Duplicate of this bug: 1546900

:jgraham, should we disable this?
I think you need to ask someone from the media team

Flags: needinfo?(james)
Pushed by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac0ff2775804
Disable mediasource-correct-frames.html for frequent failures on Windows 10. r=jmaher
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]

This bug has failed 50 times in the last 7 days. Occurs on Windows 64 bit platforms on opt and debug build types.

Recent log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=250709792&repo=mozilla-central&lineNumber=6029

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/88a9dca567d3
Disable test on windows for frequent failures. a=test-only
You need to log in before you can comment on or make changes to this bug.