select onchange keyboard

VERIFIED DUPLICATE of bug 126379

Status

()

Core
Event Handling
--
minor
VERIFIED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: jr, Assigned: joki (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

380 bytes, text/html
Details
(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a+) Gecko/20020627
BuildID:    2002062708

when using a <select> element and the keyboard to navigate through the elements
the onchange event doesn't fire until after you click somewhere else or focus on
something else.

Both IE and Opera fire the event using only the keyboard.

Reproducible: Always
Steps to Reproduce:
1. Open attached document
2. Use keyboard to navigate through select element

Actual Results:  Won't fire onchange element until after it loses focus

Expected Results:  Should fire onchange event everytime the select changes.
(Reporter)

Comment 1

15 years ago
Created attachment 89591 [details]
testcase

Comment 2

15 years ago
Browser, not engint ---> Event Handling
Assignee: rogerl → joki
Component: JavaScript Engine → Event Handling
QA Contact: pschwartau → rakeshmishra

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 4

15 years ago
verifying dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.