The Search Bar icon wrongly flickers when the browser is resized horizontally or vertically

VERIFIED FIXED in Firefox 68

Status

()

defect
P2
normal
VERIFIED FIXED
2 months ago
24 days ago

People

(Reporter: cmuresan, Assigned: aosmond, NeedInfo)

Tracking

(Regression, {regression})

Trunk
mozilla68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(2 attachments)

[Affected versions]:

  • Firefox Nightly 68.0a1, Build ID 20190503041749

[Affected Platforms]:

  • All Windows

[Steps to reproduce]:

  1. Start the browser with a new profile.
  2. Resize the browser vertically or horizontally continuously.
  3. Observe the Search Bar icon as the browser is resized.

[Expected results]:

  • The icon remains unaffected.

[Actual results]:

  • The icon flickers continuously as the browser is resized.

[Regression window]:
3:45.70 INFO: Last good revision: 7981b7ae2fafca9d8fc79f12ecbda06b220e8627
3:45.70 INFO: First bad revision: 26973fbde8f49f878e3f729cc4136085075cf5ae
3:45.70 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7981b7ae2fafca9d8fc79f12ecbda06b220e8627&tochange=26973fbde8f49f878e3f729cc4136085075cf5ae

[Notes]:

  • Attached a screen recording of the issue.

From the pushlog it looks like Bug 1353013 has caused this. @Gijs, could you please take a look at this?

Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

2 months ago

This makes no sense at all.

Does the issue go away if you disable browser.newtab.preload in about:config?

Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(cmuresan)

Yes, the issue is no longer reproducible with browser.newtab.preload set to false (a restart is needed). I've redone the regression search on macOS 10.14 and I reached the same pushlog.

Updating platforms to all because the issue is also reproducible on macOS 10.14 and Ubuntu 16.04.

Flags: needinfo?(cmuresan)
OS: Windows → All

Comment 4

Last month

So I can reproduce this. Specifically:

  1. open nightly on a clean profile (I tested on mac, per comment #3 it probably doesn't make a difference)
  2. reduce window height until you start seeing the google icon in the search box on the new tab page flicker.
  3. open about:config, toggle browser.newtab.preload to false
  4. open a new window
  5. do the same resizing, and notice the icon is fine.

I really don't know if this is gfx or imgloader or layout or docshell or tabswitching or something, but the markup/content/frontend side looks identical to me between the two tab and browser elements as well as their contents, so I don't understand where the flickering comes from. I can only assume it has something to do with the initial load/paint having been offscreen affecting how we render this node, or something.

Hopefully the gfx team can help investigate this.

Component: New Tab Page → Graphics
Product: Firefox → Core

Seems like this might be imagelib related. Andrew can you take a quick look?

Flags: needinfo?(aosmond)
Priority: -- → P2
Assignee

Comment 6

Last month

I imagine this has a similar root cause as to bug 1406134. The quick and dirty fix would be to do what we did (temporarily, although I have no found the time to work on this as of yet) for moz-page-thumb, i.e.:

https://searchfox.org/mozilla-central/rev/b9da45f63cb567244933c77b2c7e827a057d3f9b/image/imgLoader.cpp#2104

Comment 7

Last month

(In reply to Andrew Osmond [:aosmond] from comment #6)

I imagine this has a similar root cause as to bug 1406134. The quick and dirty fix would be to do what we did (temporarily, although I have no found the time to work on this as of yet) for moz-page-thumb, i.e.:

https://searchfox.org/mozilla-central/rev/b9da45f63cb567244933c77b2c7e827a057d3f9b/image/imgLoader.cpp#2104

Huh, interesting. Why would the preloading being enabled/disabled change anything here, do we perhaps not hit that path when the page isn't preloaded, ie do we avoid the re-decoding?

Duplicate of this bug: 1551900
Assignee

Comment 9

Last month

Similar to bug 1373258 and moz-page-thumb:// URIs, we are getting bitten
by the lack of caching support for non-HTTP channels. This may be
removed once bug 1406134 is implemented.

Comment 10

Last month
Pushed by aosmond@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/885f2b742a02
Load moz-extension:// URIs from the cache over reloading. r=tnikkel
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

I have verified that the issue is no longer reproducible on the latest Nightly 69.0a1 (Build ID 20190524095337) and on the latest Beta 68.0b3 (Build ID 20190521110747) on Windows 10, macOS 10.14, and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.