Closed Bug 1549017 Opened 5 months ago Closed 5 months ago

All extensions disabled due to expiration of intermediate signing cert (Workaround on standard builds)

Categories

(Toolkit :: Add-ons Manager, defect, blocker)

defect
Not set
blocker

Tracking

()

RESOLVED DUPLICATE of bug 1548973

People

(Reporter: wwjdtd, Unassigned)

Details

+++ This bug was initially created as a clone of Bug #1548973 +++

Since someone disabled commenting on the main one, I'm adding this, so I can make someone mark it as a duplicate and add the info to the main bug.

r/mudkip908 from reddit posted the following work-around:

You could also replace all occurrences of "appDisabled":true with "appDisabled":false, and "signedState":-1 with "signedState":2 in extensions.json in your profile directory. (Get to it from about:support)

Apologies for doing it this way but there are a lot of people who may go the bug report site to find workarounds. (This works on the standard build)

PLEASE MARK AS DU PE OF 1548973 AND ADD THE COMMENT.

Depends on: armagadd-on-2.0

Note Well

Hotfixing prefs to work around this issue may leave your browser in a state that conflicts with fixes applied by patches Firefox developers apply to release, beta, nightly and ESR channels and could leave the browser in a unusable state.


Full Procedure:

  1. Go to about:support in the URL bar.
  2. Open your profile directory.
  3. Open extensions.json in your preferred editor.
  4. Replace all "appDisabled":true with "appDisabled":false.
  5. Replace all "signedState":-1 with "signedState":2.
  6. Save the file.
  7. Restart Firefox.
  8. Go to about:addons in the URL bar.
  9. Disable then enable each addon to get it working again.
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Component: Add-ons Manager → General
Product: Toolkit → Invalid Bugs
Resolution: --- → INVALID
Version: 66 Branch → unspecified

I prefer the temporary fix that I outlined here:

https://www.reddit.com/r/firefox/comments/bkcjoa/all_of_my_addons_got_disabled_and_they_are_all/emggvbx/

A temporary workaround:

  1. Navigate to about:debugging
  2. Click the 'Load Temporary Add-on' button
  3. Navigate to the .xpi file in your profile directory select it and click Open.

To find your profile directory and extensions:

  • Windows:
    C:\Users\{your username}\AppData\Roaming\Mozilla\Firefox\Profiles\{profile id}.default\extensions
  • Linux:
    ~/.mozilla/firefox/{profile id}.default/extensions/
  • MacOS:
    ~/Library/Application Support/Firefox/Profiles/{profile id}.default/extensions

Or just download the extensions you want from https://addons.mozilla.org/:

  1. Right click on the 'Add to Firefox' button
  2. Choose 'Save Link As' from the menu
  3. Save the .xpi file somewhere handy
  4. Navigate to about:debugging
  5. Click the 'Load Temporary Add-on' button
  6. Navigate to the .xpi file you downloaded and open it

Restarting Firefox will remove any temporarily loaded extensions.

Component: General → Add-ons Manager
No longer depends on: armagadd-on-2.0
Product: Invalid Bugs → Toolkit
Resolution: INVALID → DUPLICATE
Duplicate of bug: armagadd-on-2.0

You can use this script to enable your installed extensions. And if that doesn't activate all your extensions, just remove this line:

if (!addon._sourceBundle.exists())
                continue;

Several fixes works for extensions, but I'm wondering is there a fix available for themes?

In light of this issue, is anyone aware what would be the fate of enterprises running older versions of Firefox (v61) with managed add-ons? Enabling studies is not an option. We have thousands of Windows systems running Firefox v61 with automatic add-ons installation.

(In reply to karthik3186 from comment #9)

… enterprises …

If I understand correctly, https://bugzilla.mozilla.org/show_bug.cgi?id=1549061#c7 shows work in progress towards distribution of a patch for Firefox ESR 60.

Firefox Extended Support Release for Your Organization, Business, Enterprise — Mozilla

We have thousands of Windows systems running Firefox v61 …

After the dusts settle around bugs such as this, consider either:

a) upgrades to a Mozilla-supported release of Firefox e.g. 66; or

b) downgrades from outdated 61 to Firefox ESR 60, although please note that I have no experience in this area.

Firefox Release Calendar - MozillaWiki

If neither (a) nor (b) will be practical, then for outdated versions of Firefox I guess that definitive advice will appear at https://blog.mozilla.org/addons/ in due course.

HTH

All of my add-ons have been removed in Firefox ESR 60.6.1 (64-bit) binary for GNU/Linux (https://ftp.mozilla.org/pub/firefox/releases/60.6.1esr/linux-x86_64/en-US/firefox-60.6.1esr.tar.bz2). I only found hotfix-update-xpi-intermediate in about:addons.

(In reply to David Hedlund from comment #12)

All of my add-ons have been removed in Firefox ESR 60.6.1 (64-bit) binary for GNU/Linux (https://ftp.mozilla.org/pub/firefox/releases/60.6.1esr/linux-x86_64/en-US/firefox-60.6.1esr.tar.bz2). I only found hotfix-update-xpi-intermediate in about:addons.

Now all add-ons magically came back right in front of my eyes when I sat and browsed.

Restrict Comments: true
You need to log in before you can comment on or make changes to this bug.