Closed Bug 1549041 Opened 1 year ago Closed 1 year ago

audible is no longer fired with tabs.onUpdated after a tab is reloaded or a navigation happened

Categories

(Core :: Web Audio, defect, P2)

67 Branch
defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- wontfix
firefox68 --- verified
firefox69 --- verified

People

(Reporter: stoically, Assigned: padenot)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

With WebExtension

  • Register tabs.onUpdated listener
  • Navigate to a website that plays sound, e.g. soundcloud.com/discover and click any playlist
  • tabs.onUpdated fires with audible changeInfo
  • Reload the page
  • Start playlist again
  • tabs.onUpdated doesn't fire with audible changeInfo

Without WebExtension

  • Open new tab
  • Navigate to a website that plays sound, e.g. soundcloud.com/discover and click any playlist
  • See the loudspeaker appear in the tab bar
  • Reload the page
  • Start playlist again
  • See no loudspeaker appear in the tab bar

Expected behavior:

tabs.onUpdated with audible changeInfo should always fire and the loudspeaker should always appear if there's sound in a tab.

Actual behavior:

tabs.onUpdated doesn't fire with audible changeInfo and the loudspeaker doesn't appear after reloading the page if there's audio in the tab.

Notes

Not sure if this is actually a WebExtension bug, since the loudspeaker is also affected.

Tested with Firefox Dev Edition 67.0b15 and Nightly 68.0a1 (2019-05-03) on Linux. And with Nightly 68.0a1 (2019-04-02) on Windows 10.

Works as expected in Firefox 66.0.3.

Component: General → Tabbed Browser
Product: WebExtensions → Firefox

I can reproduce the issue on Nightly68.0a1 windows10.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4bca50b46b48d008ecf6ef19200963056d49d222&tochange=3a9d2f91b02203fc9e538fcfe51e2cb5cf620b29

Regressed by: 3a9d2f91b02203fc9e538fcfe51e2cb5cf620b29 Paul Adenot — Bug 1528319 - Don't create a Promise when shutting down an AudioContext. r=karlt

Paul Adenot (:padenot),
Your patch seems to cause the regression. Can you please look into this?

Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Flags: needinfo?(padenot)
Regressed by: 1528319
Assignee: nobody → padenot
Component: Tabbed Browser → Web Audio
Flags: needinfo?(padenot)
Priority: -- → P2
Product: Firefox → Core

P2, fix-optional for a 67 dot release as a ride along

Pushed by padenot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/baa019d214ce
Destroy the AudioChannelAgent in CloseInternal instead of Close. r=karlt
https://hg.mozilla.org/integration/autoland/rev/6d0bd72a5967
Test that documents receive the right audio notification events when playback is done using the Web Audio API. r=karlt
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: qe-verify+

I managed to reproduce the issue using an older version of Nightly (2019-05-07) on Windows 10 x64.
I retested everything using latest Nightly 69.0a1 and Firefox 68.0b12 on Windows 10 x64, macOS 10.13 and Ubuntu 18.04 x64 and the bug is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Regressions: 1552818
You need to log in before you can comment on or make changes to this bug.