Closed Bug 1549122 Opened 7 months ago Closed 6 months ago

Prevent deadlock when search extensions upgraded on startup

Categories

(Firefox :: Search, defect, P1)

68 Branch
defect
Points:
2

Tracking

()

RESOLVED FIXED
Firefox 68
Iteration:
68.4 - Apr 29 - May 12
Tracking Status
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 + fixed

People

(Reporter: daleharvey, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

(Whiteboard: cert2019)

Attachments

(1 file)

https://bugzilla.mozilla.org/show_bug.cgi?id=1549075#c12 explains a deadlock that could be hit if search extensions were upgraded on startup, that bug is being fixed in a different way so this will no longer get hit, but we should prevent against it

Priority: -- → P3

I'm going to argue that this is a P1 since there is a potential for a deadlock if updates happen on startup, and if that happens we're all kinds of broke.

Priority: P3 → P1
See Also: → 1549075
Attachment #9062890 - Attachment description: Bug 1549122 - Dont await on SS.init. → Bug 1549122 - Duct tape to prevent deadlock when search extensions upgraded on startup.
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/a40e9f3da7ac
Duct tape to prevent deadlock when search extensions upgraded on startup. r=mikedeboer a=Aryx
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 68 → ---

I'm looking for a permanent fix.

Assignee: nobody → rob
Status: REOPENED → ASSIGNED

Assuming other branches are affected; please change the flag if that's not correct.

My understanding is this bustage relates to the new search-engines-as-addons code, so 66 and 67 are unaffected. Mike (or someone else on the search team), can you confirm and if so update the release flags accordingly? Thanks.

Flags: needinfo?(mdeboer)

Hey look, a mid-air.

Flags: needinfo?(mdeboer)
Assignee: rob → mixedpuppy
Whiteboard: cert2019
Duplicate of this bug: 1549277

reassigning to dale since a patch has landed on this. I'll create a new bug for overall refactoring of the search extension loading.

Assignee: mixedpuppy → dharvey
Status: ASSIGNED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → FIXED

Shanes refactor will likely fix this in a more elegant way on the addon side but will limit this bug for tracking the quick fix

Target Milestone: --- → Firefox 68
Iteration: --- → 68.4 - Apr 29 - May 12
Points: --- → 2
You need to log in before you can comment on or make changes to this bug.