Closed Bug 1549216 Opened 3 years ago Closed 3 years ago

MSI Installer for 66.0.4 exits after 'collecting data for configuration'

Categories

(Firefox :: Installer, defect)

Desktop
Windows
defect
Not set
major

Tracking

()

RESOLVED INVALID
Tracking Status
relnote-firefox --- -
firefox-esr60 --- unaffected
firefox66 - wontfix

People

(Reporter: callahad, Unassigned)

References

Details

Seeing a few reports of installer failures on Reddit following the 66.0.4 point release.

"I have a problem with manual installation. After I double click, it starts to work but then Firefox window opens and that's it. When I check version it is still 0.3 instead of 0.4." (link)

"downloaded. ran. never started.. sat 'collecting data for configuration' then exited" (link)

"Use the exe not the msi...same thing happened to me" (link)

Not much information beyond that, unfortunately, and I don't have a Windows box to test on myself.

See Also: → armagadd-on-2.0
Summary: MSI Installer for 66.0.4 exits after 'collecting information' → MSI Installer for 66.0.4 exits after 'collecting data for configuration'

So, this seems to be newly reported (as far as I can tell) for 66.0.4

Matt anything stand out here to you from a code side that could explain it.
Ritu, n-i is to you from a relman perspective/heads up because of the plans around the dot release incase it is related to the changes we made there.

Flags: needinfo?(rkothari)
Flags: needinfo?(mhowell)

Confirmed this behavior on Windows 10 x64 with the 66.0.4 MSI build.

OS: Unspecified → Windows
Hardware: Unspecified → Desktop
Restrict Comments: true

I'm adding this to the 66.0.4 relnotes.

This seems like expected behavior. The older MSI installers are nearly silent. If users want to have a traditional install experience they should use the EXE. The MSI is for command line deployment.

Severity: normal → major

This is all normal and expected; the installer is running in the background, but it doesn't provide any status updates to the MSI service, so there's nothing for MSI to update its UI from. As Kevin pointed out, our MSI installer is not really intended to be run interactively.

The first reddit user linked in comment 0 who reported still seeing the old version after running the MSI later replied that they had background processes still running and blocking the installer from working, so there's no bug there either.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(rkothari)
Flags: needinfo?(mhowell)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.