Port Bug 1011978 to SeaMonkey. Don't show need to update notifications if MOZ_UPDATER is not defined.

RESOLVED FIXED in seamonkey2.65

Status

defect
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.65

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

Details

Attachments

(2 attachments)

In private or distro builds a warning notification about an outdated build will be shown after some time. It can be overridden with app.updatecheck.override but does not make sense if the updater is not enabled. In this case the user is reposible for making sure he/she is up to date.

+++ This bug was initially created as a clone of Bug #1011978 +++

User Agent: Mozilla/5.0 (X11; FreeBSD i386; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140217071214

Steps to reproduce:

Firefox 27, installed on 2014-02-17, had been running for a couple of weeks, with ~ 20-30 open tabs. I think that all restarts for a year or two have been crash recoveries.

Actual results:

Every couple of hours or so, the status bar appears, containing the message: "It looks like you haven't started Firefox in a while. Do you want to clean it up for a fresh, like-new experience? And by the way, welcome back!". In the lower right corner, there's a button labelled "Reset Firefox", and a close button. When I click the close button, sometimes the message immediately repeats for a couple of times, so I need to click the close button multiple times to get rid of the message (and the status bar) for a while.

Expected results:

The message should not appear at all.

The text "welcome back" is nonsense when Firefox has been running all the time. Checks like this should only be done at Firefox launch, and accordingly, the message should only show up on Firefox launch. It should not repeat until next launch.

Moreover, the check should compare the current date with the latest termination date, no matter if normal of abnormal termination, not with (as it seems) the latest fresh session start date.

Tested in 2.53. esr60 and c-c need a different syntax for the lazygetter only.

Attachment #9064307 - Flags: review?(iann_bugzilla)
Attachment #9064307 - Flags: approval-comm-esr60?
Attachment #9064307 - Flags: approval-comm-esr52?

esr52 version

Comment on attachment 9064307 [details] [diff] [review]
1549391-expirecheck.patch

r/a=me
Attachment #9064307 - Flags: review?(iann_bugzilla)
Attachment #9064307 - Flags: review+
Attachment #9064307 - Flags: approval-comm-esr60?
Attachment #9064307 - Flags: approval-comm-esr60+
Attachment #9064307 - Flags: approval-comm-esr52?
Attachment #9064307 - Flags: approval-comm-esr52+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/c8d25405abfe
Do no show the notification for an expired build if the updater is not available. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.